Issue 76414 - Non-breaking hyphens are stripped before spellchecking
Summary: Non-breaking hyphens are stripped before spellchecking
Status: CLOSED DUPLICATE of issue 64400
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: current
Hardware: PC Linux, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-04-16 17:22 UTC by hatapitk
Modified: 2009-03-30 23:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hatapitk 2007-04-16 17:22:19 UTC
In Finnish, HYPHEN-MINUS is a word character, and current OpenOffice.org 
correctly handles it as such (see issue #58513). We have recently discussed 
this at dev@fi.openoffice.org and concluded that the behaviour should be 
extended to cover NON-BREAKING HYPHEN as well.

But after experimenting with such change I discovered that non-breaking 
hyphens are completely stripped from words before they are send to the 
spellchecking component for processing. Steps to reproduce:

- Add [:name = NON-BREAKING HYPHEN:] to $ALetter in 
i18npool/source/breakiterator/data/dict_word_fi.txt and 
i18npool/source/breakiterator/data/count_word_fi.txt

- Enter "Kaakkois-Suomi" in Writer using HYPHEN-MINUS as the hyphen
  -> spellchecker component receives word "Kaakkois-Suomi"; this is OK.

- Enter "Kaakkois-Suomi" in Writer using NON-BREAKING HYPHEN as the hyphen
  -> spellchecker component receives word "KaakkoisSuomi". This is wrong, I 
would expect to get "Kaakkois-Suomi" (maybe with the non-breaking hyphen 
converted to an ordinary hyphen).

It seems like the same bug is present in the hyphenator as well, although 
there it is less likely to cause any real problems.
Comment 1 michael.ruess 2007-04-17 07:50:18 UTC
Reassigned to SBA.
Comment 2 lohmaier 2009-03-30 23:47:38 UTC
duplicate.

*** This issue has been marked as a duplicate of 64400 ***
Comment 3 lohmaier 2009-03-30 23:48:22 UTC
closing duplicate