Issue 76515 - Decimal places should be "undefined" for default view.
Summary: Decimal places should be "undefined" for default view.
Status: CLOSED DUPLICATE of issue 46511
Alias: None
Product: Calc
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-04-19 13:32 UTC by ftack
Modified: 2009-11-01 08:07 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ftack 2007-04-19 13:32:22 UTC
Opposite to other spreadsheets, calculate requires a fixed number of decimal
places for the "general" number format. The number of decimal places is
controlled using tools - Options - OOo.Calc - Calculate, "Decimal places". As a
result, numbers with a large number of digits (depending on the current cell
width) will more rapidly be represented as "##" than in other spreadsheets.

For example, with a decimal setting of 3, following number

12345.6789

might be displayed as ## in Calc (depending on the column width)

while under the same circumstances, competing spreadsheets would just display
less decimals, e.g.

12345.6

and only display ## if also the integer part doesn't fit in the cell anymore.

The latter approach allows for greater flexibility in the default display of
numbers. In Calc, a user has to recur more rapidly to adapting the cell width
(which will affect the whole column) or changing the "Decimal places" option
(which will affect the whole spreadsheet).

Thus, I would suggest that the "Decimal places" option in "Calculate"
dissappears, and that instead Calc handles the default display in a more
advanced and flexible way, i.e.

* Show the integer part and as many decimals that fit
* Even better yet for numbers that won't fit: switch to exponential format
Comment 1 Rainer Bielefeld 2007-07-07 07:34:35 UTC
This might be interesting for EXCEL import, if EXCEL really limits the number of
shown decimals due to cell width 
Comment 2 erickvaalen 2008-02-09 18:15:01 UTC
I very much agree with this. All spreadsheets that I have used in the past
(Quattro Pro, Lotus, Excel) have as the default format a "general format" which
behaves as proposed above, and switches to scientific notation when necessary.

Today I tried to use OOo for a calculation, and it gave me "0". I didn't believe
it, and by changing the format I discovered that it was something like 0.00001.
I consider this to be very bad.
Comment 3 oc 2008-07-15 10:43:20 UTC
reassigning features and enhancements to user requirements@openoffice.org which
will be the default owner for those tasks (was introduced some time ago)
Comment 4 ftack 2009-07-30 13:07:55 UTC
Enter a number "-0.001". It is displayed by default as "0". This is simply crazy
and unacceptable.
Comment 5 Regina Henschel 2009-10-16 19:01:25 UTC
This problem is tracked in issue 46511. Please move your votes.

*** This issue has been marked as a duplicate of 46511 ***
Comment 6 Mechtilde 2009-11-01 08:07:17 UTC
duplicate -> closed