Issue 76601 - Report Wizard crashes office
Summary: Report Wizard crashes office
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.2
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: marc.neumann
QA Contact: issues@dba
Keywords: oooqa, regression
Depends on:
Reported: 2007-04-23 07:23 UTC by drewjensen.inbox
Modified: 2013-08-07 15:45 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

example db (71.23 KB, application/vnd.sun.xml.base)
2007-04-23 07:24 UTC, drewjensen.inbox
no flags Details
Error log from first use of RW on newly creaed base file (16.89 KB, text/plain)
2007-04-25 03:36 UTC, drewjensen.inbox
no flags Details
Error log when the Base attached to this issue was used (16.84 KB, text/plain)
2007-04-25 03:37 UTC, drewjensen.inbox
no flags Details
stack trace for crash report r5sf9c (13.34 KB, text/plain)
2007-04-25 13:59 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drewjensen.inbox 2007-04-23 07:23:14 UTC
This is with 2.2.1 680m_15 build 9140.

WinXP Home SP2, JRE 1.6.0, embedded base file.

Running the report wizard quietly kills OOo when finished button clicked.

Running reports made under 2.2 Stable appears to work without a problem.

Editing an existing report file appears to work without a problem.

Attached is a Base file with a report made under 2.2. Attempting to recreate the
report under 2.2.1 caused consistent crash. Then attempting to create any
report, with no grouping at all continued the crashes.
Comment 1 drewjensen.inbox 2007-04-23 07:24:27 UTC
Created attachment 44598 [details]
example db
Comment 2 Mechtilde 2007-04-23 08:39:37 UTC
I can confirm it 

It works in 2.2 final and in SRC680_m209 but not in OOF680_m15
So it's a regression.I set to P2

Comment 3 Frank Schönheit 2007-04-24 09:26:02 UTC
Hmm, cannot reproduce. Do you mind adding a more detailed description? Any
special options you set in the wizard?
Comment 4 Regina Henschel 2007-04-24 13:46:07 UTC
I can confirm the crash too.
It is an error in OOF680_m15.
For example create a report in the attached database file on table "Task_Types"
with all fields. You need only to go through the wizard with "Next".
It crashes on "finish" in the last step, with every embedded HSQL that I tried.
Comment 5 drewjensen.inbox 2007-04-24 15:27:10 UTC
Still having the same problem reports and it seems to be java related. For
example I can't reach any of the MySQL databases under 2.2.1 ( I was going to
test RW against these to see if it was HSQL only) I receive the error that
com.mysql.jdbc.driver can not be loaded. Checking options I am using JRE 1.6.0
and the mysql connector 5.0.3 jar is included in the class path.

It seems now also the 2.2 stable is having issues with connecting to MySQL also
- however if I create new Base file using MySQL everything is OK.

As for other options settings I changed none after the install - there was one
anomaly however during install. 2.3 Dev build 206 was already on my machine and
2.2.1 refused to install until I removed that distribution, which I did using
the control panel. ( I have never had this happen before ) What I did NOT do was
run a registry cleaner after removing 2.3, so who knows maybe something is left

The only other software that was added to my machine after 2.2.1 was the latest
Pentaho Report Designer. This brought along all new jar files for hsqldb, MySQL
connector 5.0.5 and a slew of others. Looking at the environment variable
classpath again I notice that it was updated to include these in the path, with
an indirect path form the Pentaho Report Designer home directory. Perhaps these
are getting ahead of the OOo expected files?

Given all this I will take the following steps - backout OOo 2.2, backout OOo
2.2.1, backout Pentaho, clean the registery, remove the directories added in
application_data directory tree. Remove the classpath environment variable.

Then try a clean install of just 2.2.1 and see. I'll let you know when I have
finished. Assuming that 2.2.1 is running RW with no problems after this, I will
go ahead and reinstall Pentaho RD and see if the issue comes back.

I'll let you know how this goes.
Comment 6 drewjensen.inbox 2007-04-25 03:31:15 UTC
Alright, I followed the steps I outlined, completely removed all installs of
OOo2  and completely removed the Pentaho Report Designer files, cleaned the
windows registry, removed all OOo created directories. Installed 2.2.1m15 build

No change. 

However I now realize that JRE1.6 is creating error logs. I am attaching two of
these. The first when I used RW on a file created after this install. The second
when I ran RW on the same db as attached to this issue earlier. 
Comment 7 drewjensen.inbox 2007-04-25 03:36:17 UTC
Created attachment 44653 [details]
Error log from first use of RW on newly creaed base file
Comment 8 drewjensen.inbox 2007-04-25 03:37:22 UTC
Created attachment 44654 [details]
Error log when the Base attached to this issue was used
Comment 9 drewjensen.inbox 2007-04-25 04:21:17 UTC
To follow up on this. I removed 2.2.1 and went back to 2.2 stable - nothing else
done to machine in between. Using the attached database the report wizard is
working as expected.
Comment 10 Frank Schönheit 2007-04-25 09:34:03 UTC
Andrew, I suppose when you say "2.2.1" you mean the OOF680_m15 (or similar) build.

To both Andrew and Regina: Where did you get those builds from? I don't find
them at the official download pages (but that might be only me).
Comment 11 Frank Schönheit 2007-04-25 09:41:32 UTC
still unable to reproduce with "Task_Types" and all default options, with
OOF680_m15 from Hamburg's releng repository, with JRE 1.6.0 (+accessibility).
Comment 12 Mechtilde 2007-04-25 10:34:15 UTC
I try it again.

this time I could send a crash report

Comment 13 Frank Schönheit 2007-04-25 10:48:37 UTC
could you name the report ID here, please?
Comment 14 Mechtilde 2007-04-25 10:58:15 UTC
it's r5sf9c
Comment 15 drewjensen.inbox 2007-04-25 12:57:48 UTC
I am installing ( or think I am, at this point maybe I have made some real mix
up ) from the file

The file was downloaded on 4/17/07

Comment 16 drewjensen.inbox 2007-04-25 13:03:06 UTC
sorry, I checked my logs I downloaded the file from

on 4/17

That is one of the mirror sites here in the USA.
Comment 17 Frank Schönheit 2007-04-25 13:59:00 UTC
Created attachment 44675 [details]
stack trace for crash report r5sf9c
Comment 18 Frank Schönheit 2007-04-25 14:04:29 UTC
Attached is the log for the crash report with ID r5sf9c.

Interestingly, this crashs deep in the Writer core, when saving the final document.

I know that a first build of OOF680m15 had an incompatibility which slipped
release engineering's attention, and which lead to a lot of applications
crashing upon saving and/or loading documents. Internally in Hamburg, there has
been a new "hot fix build" of m15, but it might be that the first, corrupted
build escaped into the wild, and that the version you're using is exactly this
broken version.

What speaks *against* this theory is that the build ID is 9140 in my case, too -
and it should be different from yours if we really had different builds.
However, who knows whether RE perhaps forgot to increase the build ID?

What I would suggest for the moment is to wait for m16, and see if the problem

Alternatively, if anybody who actually encounters the problem has the chance to
verify the following MD5 checksums:

  sw680mi.dll: F5EC193AC830C140200F1C11629035D9
  swd680mi.dll: AAE429795103CC528C8E864C52B400F2
  swui680mi.dll: B4EC991B916C911133C991E439FD15E4

, then this might give us a hint whether the versions we use are really the same.

Comment 19 Frank Schönheit 2007-04-25 14:07:52 UTC
(I could probably also create MD5 sums for the Linux libs, if requested. For the
moment, I hope for the Windows users of you :)
Comment 20 drewjensen.inbox 2007-04-25 14:22:41 UTC
Using the latest fciv.exe from MS I get these values for MD5

// File Checksum Integrity Verifier version 2.05.
223b06ccbd47aae51a427ca83b7cee5f sw680mi.dll
// File Checksum Integrity Verifier version 2.05.
b59860ce05950abd6d3c44592b6862ef swd680mi.dll
// File Checksum Integrity Verifier version 2.05.
d4acae1de5eb9d40d1ffd4dd0173aa33 swui680mi.dll

Comment 21 Frank Schönheit 2007-04-25 14:48:13 UTC
which means we in fact have different lib versions, though both our OOo versions
have the same build ID :(

Let's wait for m16, please. Meanwhile, I'll see whom in Release Engineering I
can kick for causing this lot of wasted time :-\
Comment 23 Frank Schönheit 2007-05-02 09:57:13 UTC
I have a confirmation from release engineering meanwhile that build IDs get not
incremented without a source change (for various reasons). Since there was an
incompatibility detected which needed only rebuilding, but no source change,
there exist different builds with the same ID, but different libs.

So, let's see what m16 brings here. I bet the problem is solved by then.
Comment 24 Regina Henschel 2007-05-13 00:21:50 UTC
For me it crashes no longer with OOo221 RC1 de on WinXP.
Comment 25 Frank Schönheit 2007-05-14 08:29:28 UTC
Good to hear. Andrew?
Comment 26 drewjensen.inbox 2007-05-14 20:11:49 UTC
Using RC1, there seems to be no problem here either.
Comment 27 Frank Schönheit 2007-05-15 08:56:35 UTC
thanks for the feedback - closing then