Issue 76634 - Inconsistent symbols used in search dialog
Summary: Inconsistent symbols used in search dialog
Status: CLOSED DUPLICATE of issue 46165
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 2.2 RC4
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-23 19:46 UTC by raindrops
Modified: 2009-04-24 10:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description raindrops 2007-04-23 19:46:29 UTC
Actually usi9ng 2.3 dev m709.

The search GUI uses two different symbols to represent the paragraph break:
$ if you are in "Search for" box.
\n if you are in "Replace with" box.

Both symbols cannot be used interchangeably.

This is a design blunder, because- 
(a) the definition of "paragraph break" is changed on-the-fly, and 
(b) the standard definitions of RegEx syntax are violated.
Comment 1 eric.savary 2007-04-24 01:42:13 UTC
ES->SBA: I think it's a well known one...
Comment 2 raindrops 2007-04-24 17:23:51 UTC
Further, as pointed out in Issue 64291 (see last post by ufi) , the $ does not
even work consistently:

In a file, enter the following 

111111ENTER
ENTER
ENTER
222222

(Where you see "ENTER", press the ENTER key.)

Now search for $ and replace it with DOLLAR.
Only two of the ENTER keystrokes are replaced; the third is not.

(You can take this part as an extension of the earlier problem. But if you want
a new issue raised for this part, then Issue 64291 is already there. Please let
me know.
Comment 3 nataliamhitekschool 2009-04-20 00:37:42 UTC
I can reproduce in OOO310m9 for Windows Vista
Comment 4 stefan.baltzer 2009-04-22 14:31:01 UTC
Another one on the pile of "Regular Expressions far from perfect".

Note that "waiting and wishing" will not change anything until someone sponsors
developer ressouces for this. 

Community developers, feel free to attack the area of Regular Expressions!


*** This issue has been marked as a duplicate of 46165 ***
Comment 5 stefan.baltzer 2009-04-24 10:38:33 UTC
Closed.