Issue 76699 - for documents with author=OOo-username, page is left aligned after load, centered after window resize
Summary: for documents with author=OOo-username, page is left aligned after load, cent...
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 680m209
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: needmoreinfo
Depends on:
Blocks: 80294
  Show dependency tree
 
Reported: 2007-04-25 21:37 UTC by norbert2
Modified: 2013-08-07 14:42 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Document to reproduce the bug (7.70 KB, application/vnd.oasis.opendocument.text)
2007-04-25 21:39 UTC, norbert2
no flags Details
after_load_before_resize.png (97.07 KB, image/png)
2007-04-26 17:33 UTC, norbert2
no flags Details
after_resize.png (96.09 KB, image/png)
2007-04-26 17:34 UTC, norbert2
no flags Details
680m210_after_load_before_resize.png (77.29 KB, image/png)
2007-04-26 20:54 UTC, norbert2
no flags Details
680m210_after_resize.png (71.72 KB, image/png)
2007-04-26 20:55 UTC, norbert2
no flags Details
username_to_reproduce_the_bug.png (45.93 KB, image/png)
2007-04-28 20:19 UTC, norbert2
no flags Details
patch to center documents (1.68 KB, patch)
2007-08-27 15:01 UTC, Oliver Specht
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description norbert2 2007-04-25 21:37:30 UTC
Issue 1761 has introduced centered pages in writer. But the attached document
opens with left aligned page. It is centered after resizing the OOo-window.
Comment 1 norbert2 2007-04-25 21:39:59 UTC
Created attachment 44691 [details]
Document to reproduce the bug
Comment 2 norbert2 2007-04-25 21:41:44 UTC
Only some documents that I have show this problem. I have not found out where
they are different to the ones that don't have this problem.

(I have found this bug on Linux.)
Comment 3 eric.savary 2007-04-26 13:16:35 UTC
WORKSFORME.
Have you tested this with a >m208?
Comment 4 norbert2 2007-04-26 17:28:26 UTC
I hav tested it with
OOo-Dev_SRC680_m209_Win32Intel_install.exe
and
OOo-Dev_SRC680_m209_LinuxIntel_install.tar.gz

Both, Linux and Windows versions show the bug!

I will attach screenshots of the Windows version.
Comment 5 norbert2 2007-04-26 17:33:37 UTC
Created attachment 44711 [details]
after_load_before_resize.png
Comment 6 norbert2 2007-04-26 17:34:21 UTC
Created attachment 44712 [details]
after_resize.png
Comment 7 norbert2 2007-04-26 17:37:47 UTC
(New, blank documents always open correctly centered.)
Comment 8 norbert2 2007-04-26 19:46:45 UTC
I just have downloaded and tested
OOo-Dev_SRC680_m210_Win32Intel_install.exe:

The bug is still there.
Comment 9 norbert2 2007-04-26 20:54:08 UTC
I will attach screenshots of 680m210.
Comment 10 norbert2 2007-04-26 20:54:57 UTC
Created attachment 44714 [details]
680m210_after_load_before_resize.png
Comment 11 norbert2 2007-04-26 20:55:45 UTC
Created attachment 44715 [details]
680m210_after_resize.png
Comment 12 eric.savary 2007-04-27 11:39:29 UTC
I just installed the same build as yours.
Yes I see your screenshots.
But I cannot reproduce this. Before or after zooming, the view is centered.
Can you try to deactivate most of the programs shown in your Windows Task bar?
Delete your User directory and restart OOo?
Install an new printer and make it default?
Comment 13 norbert2 2007-04-28 16:34:31 UTC
Thanks for your interest, es. But all these things cannot be the reason since I
see this bug on Windows and Linux and I delete the OOo-profile folder before
each update of OOo.
Comment 14 norbert2 2007-04-28 16:48:15 UTC
I found out how the reproduce the bug:

You have to insert my username in your OOo settings. You can see it in the
attached screenshot.

If I leave the username fields blank, the document opens centered!


Writer restores cursor position after loading of documents if document author =
username. Perhaps there is some bug in this function.
Comment 15 norbert2 2007-04-28 20:19:25 UTC
Created attachment 44755 [details]
username_to_reproduce_the_bug.png
Comment 16 eric.savary 2007-05-04 11:01:08 UTC
@os: There's a collision between issue 33307 (Open document behavior) and the
new implemented issue 1761 (centered view). The left aligned view appears to be
stored with the cursor position.
Comment 17 norbert2 2007-05-20 09:49:17 UTC
This bug has really to be fixed in 2.3 final release. This behavior in a final
version would lead to very buggy impressions about StarOffice/OpenOffice.
Comment 18 Oliver Specht 2007-06-21 12:35:02 UTC
Fixed in cws os98 in sw/source/ui/uiview/view.cxx
Comment 19 Oliver Specht 2007-06-29 10:04:37 UTC
Reassigned for verification
Comment 20 michael.ruess 2007-07-10 11:14:48 UTC
MRU->OS: when the OOo Window is (almost nearly) screensize, the issue still occurs.
Comment 21 michael.ruess 2007-07-10 11:18:12 UTC
Reopened.
Comment 22 Oliver Specht 2007-07-12 07:42:23 UTC
Target changed to 2.4
Comment 23 Oliver Specht 2007-08-27 15:01:01 UTC
Created attachment 47801 [details]
patch to center documents
Comment 24 Oliver Specht 2007-08-27 15:02:01 UTC
Added mba to cc
Comment 25 Oliver Specht 2007-08-28 15:33:26 UTC
Target changed to 2.3
Fixed in cws os102 in 
sw/source/ui/uiview/view.cxx
and additionally two 'inline' directives have been removed in 
sw/source/ui/uiview/viewport.cxx
sw/source/ui/inc/view.hxx
Comment 26 Oliver Specht 2007-08-29 14:12:10 UTC
Reassigned for verification
Comment 27 michael.ruess 2007-08-30 15:09:16 UTC
Verified fix in CWS os102.
Comment 28 nudimmud 2007-09-18 08:12:02 UTC
Well I found a bug something similar to this in 2.3RC3

Take a look at Issue 81638
Comment 29 stefan.baltzer 2007-09-18 15:17:29 UTC
SBA: OK in OOG680_m5 (OOo 2.3). Closed.