Issue 76734 - Using under COM+
Summary: Using under COM+
Alias: None
Product: udk
Classification: Code
Component: code (show other issues)
Version: OOo 2.2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: AOO PleaseHelp
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2007-04-27 01:47 UTC by jvernon
Modified: 2013-02-07 21:51 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Test Case (9.88 KB, application/x-compressed)
2007-04-27 01:48 UTC, jvernon
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jvernon 2007-04-27 01:47:48 UTC
I'm trying to get to run under COM/DCOM for use on an 
unattended server.
To do this I create a Component Package under COM+. It works fine. However if 
I change the user from the Interactive User (me) to a named user (also me) 
then I start getting errors when I try to create an instance of the Service 
"Retrieving the COM class factory for component with CLSID {82154420-0FBF-11D4-
8313-005004526AB4} failed due to the following error: 80080005." [Server 
execution failed]
I know the documentation for says that the identity of the 
service manager must be set to “Interactive User”. However it doesn't explain 
why and it shouldn't be necessary.

I enclose a simple test case to demonstrate the issue.
Comment 1 jvernon 2007-04-27 01:48:48 UTC
Created attachment 44718 [details]
Test Case
Comment 2 Mathias_Bauer 2007-04-27 11:32:05 UTC
changed component
Comment 3 Mathias_Bauer 2007-04-27 11:32:55 UTC
Noel, I think that's nothing you want to dive in. :-)
Changing owner to jl.
Comment 4 joachim.lingner 2007-04-27 12:32:01 UTC
Please everyone feel free to send in patches or recommend solutions.
Comment 5 lijuanwu 2010-10-26 20:40:53 UTC
I got the same error and want to know if somebody has any idea how to fix it. 
The wired thing is at some point back in early September 2010 it worked. I 
didn't touch it for a while until user sent me the error recently. So I 
uninstalled and installed OpenOffice again, Set the service in Port 8100. Did 
everything I could. Checked all the permissions on server.  No luck so far.
my environment:
Windows Server 2003 SP2.  The OpenOffice version is 3.2.1. I am using the .NET 
web application to access OpenOffice to convert single .doc or dcox to pdf. To 
code is like this

Type tServiceManager = Type.GetTypeFromProgID("", 

                //Create a new ServiceManager Com object using our
                //ServiceManager type object
                object oServiceManager = System.Activator.CreateInstance

The error is pointing to creatInstance line. I am thinking what changes has 
been made on the server could possibly caused this failure. What can I do to 
fix it. Any help will be greatly appreciated.