Issue 77189 - sync ooo-build & oovbapi modules
Summary: sync ooo-build & oovbapi modules
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: scripting (show other issues)
Version: OOo 2.2 RC4
Hardware: All Unix, all
: P3 Trivial (vote)
Target Milestone: OOo 2.4
Assignee: sled10guy
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-05-10 12:11 UTC by noel.power
Modified: 2009-07-20 14:52 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
test client and sample test documents (894.21 KB, application/octet-stream)
2007-11-21 12:52 UTC, noel.power
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description noel.power 2007-05-10 12:11:20 UTC
I want to sync the object module work from ooo-build to the oovbaapi module,
since the initial code drop many objects have changed, also changes to introduc
new uno service/interface bits, some porting from the helperapi etc
Comment 1 utomo99 2007-07-04 04:52:45 UTC
add cc
Comment 2 utomo99 2007-07-04 06:05:06 UTC
change target as already included on cws npower8
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=SRC680%2Fnpower8
Comment 3 pavel 2007-08-02 15:36:21 UTC
reset target
Comment 4 mmeeks 2007-08-02 16:19:27 UTC
looks like (for QA reasons) npower[78] won't get into 2.3 unfortunately, target
at OO.o 2.4 instead.
Comment 5 noel.power 2007-11-13 11:06:28 UTC
as of today ( see date of comment ) the source code for the implementation of
vba interop model is the same as in ooo-build [1]

marking as fixed to put the cws to ready for QA

[1] of course as time goes on this will change again ( but I will try to make
all changes even to ooo-build in a new cws )  
Comment 6 noel.power 2007-11-21 12:37:12 UTC
->qa
Comment 7 noel.power 2007-11-21 12:50:16 UTC
so, how can we test the api implementation is in sync with ooo-build, well we
cant is the simple answer. But I want to start introducing some automated
testing to the vba bits. In the cws there are directories

sc/source/ui/vba/testvba &
sc/source/ui/vba/TestDocuments

setting environment variable OFFICEPATH ( pointing to installed office ) and
running dmake will test log files created from the test documents against ( known ) 
 results.

This however is impractical for QA, also the java client sucks, so I have
rewritten the test client in c++ ( easier to make standalone ) and I am going to
attach a zip file containing all of the scripts, TestDocuments ( and the
testclient exe ) to run and compare the results from the testdocuments.

simply unzip the zipfile, cd into the testHarness/testvba directory and
depending on you platform follow the instructions in the README


Comment 8 noel.power 2007-11-21 12:52:04 UTC
Created attachment 49792 [details]
test client and sample test documents
Comment 9 sled10guy 2007-12-05 21:27:16 UTC
Passed Regression testing on SLED10SP1 using vbaapi-patched.oxt and on Windows
XP using vbaapi.oxt and an updated win/logs/Ranges.log.
Comment 10 thorsten.ziehm 2009-07-20 14:52:19 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues