Issue 77200 - Assertion in config manager when installing extension
Summary: Assertion in config manager when installing extension
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m210
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Stephan Bergmann
QA Contact: issues@framework
URL:
Keywords:
: 66356 79949 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-05-10 15:15 UTC by joachim.lingner
Modified: 2013-08-07 15:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description joachim.lingner 2007-05-10 15:15:58 UTC
When installing and uninstalling an extension that contains xcs and xcu files
there is a assertion at:
configmgr/source/treecache/treemanager.cxx,
void TreeManager::nodeUpdated(TreeChangeList& _rChanges)

It says: TreeManager::nodeUpdated : cannot access cache !"
and 2 lines below: "TreeManager::nodeUpdated : node not found in cache!".

To reproduce this you could use a extension in desktop/test/deployment/options
Comment 1 Stephan Bergmann 2007-05-10 15:50:17 UTC
.
Comment 2 Stephan Bergmann 2007-07-24 16:28:53 UTC
*** Issue 79949 has been marked as a duplicate of this issue. ***
Comment 3 Stephan Bergmann 2007-08-07 15:09:31 UTC
*** Issue 66356 has been marked as a duplicate of this issue. ***
Comment 4 Stephan Bergmann 2011-01-21 17:28:59 UTC
meanwhile, configmgr code has been re-written completely
Comment 5 Stephan Bergmann 2011-01-21 17:29:28 UTC
.