Issue 77209 - Calc cannot import XLS from SAP
Summary: Calc cannot import XLS from SAP
Status: CLOSED DUPLICATE of issue 70981
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.2
Hardware: PC All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-10 16:35 UTC by openskm
Modified: 2007-07-06 13:05 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample XML from SAP (2.30 KB, application/x-compressed)
2007-05-10 16:36 UTC, openskm
no flags Details
Opened in Calc (37.83 KB, image/png)
2007-05-10 16:37 UTC, openskm
no flags Details
Opened in Writer/Web (default action) (43.51 KB, image/png)
2007-05-10 16:38 UTC, openskm
no flags Details
Opened in Excel (47.10 KB, image/png)
2007-05-10 16:38 UTC, openskm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description openskm 2007-05-10 16:35:12 UTC
Calc cannot import XLS exported from SAP properly. In fact this XLS is not in
binary XLS format but it is a special HTML file. OOo opens it in Writer/Web by
default (writer.png) but it can be opened as Calc HTML in Calc, too (calc.png).
The problem is that this special HTML file contains embedded XML snippets and
OOo cannot handle these. The expected behaviour is that OOo opens this file like
MS Excel does (excel.png).
Comment 1 openskm 2007-05-10 16:36:11 UTC
Created attachment 45022 [details]
Sample XML from SAP
Comment 2 openskm 2007-05-10 16:37:17 UTC
Created attachment 45023 [details]
Opened in Calc
Comment 3 openskm 2007-05-10 16:38:14 UTC
Created attachment 45024 [details]
Opened in Writer/Web (default action)
Comment 4 openskm 2007-05-10 16:38:56 UTC
Created attachment 45025 [details]
Opened in Excel
Comment 5 kpalagin 2007-06-08 05:13:59 UTC
Confirming with 2.2 on WinXP - as described.
Comment 6 frank 2007-07-06 13:04:36 UTC
double to Issue 70981

*** This issue has been marked as a duplicate of 70981 ***
Comment 7 frank 2007-07-06 13:05:13 UTC
closed double