Issue 77319 - deletion of the object with backspace crashes Writer
Summary: deletion of the object with backspace crashes Writer
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 680m211
Hardware: All Windows 2000
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 78309 78512 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-05-14 00:02 UTC by mmenaz
Modified: 2013-08-07 14:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
sample crash test (10.61 KB, application/vnd.oasis.opendocument.text)
2007-05-14 00:04 UTC, mmenaz
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mmenaz 2007-05-14 00:02:54 UTC
I've copy-pasted the content from web:
http://www.howtoforge.com/lintrack_lan_gateway_openvpn_bridge
into the .odt doc attached.
If you go with the cursor to the "AAA" on the right of the object (that seems to
be a web frame... how can I tell what the object is? Right clicking and
selecting Properties has no effect), and start delete with backspace, once you
delete the object Writer crashes.
It happens under m210 GNU/Linux debian sid and m211 Win2K.
Don't know if relevant, but I'm using Italian dictionary, so almost all words
are red-underlined by the spell checker. Also, as soon as you open the document,
if you select some text the text is not visually marked as selected (no white on
black background)
Comment 1 mmenaz 2007-05-14 00:04:02 UTC
Created attachment 45096 [details]
sample crash test
Comment 2 michael.ruess 2007-05-14 14:32:14 UTC
MRU->MAV: please have a look. Open the document in Writer, place cursor between
the floating frame object and the "AAA", delete the frame with Backspace -> crash
Maybe the change by internal task #107330 deals with this. In 680m209 this
worked fine.
Crash report ID r466hc.
Comment 3 mikhail.voytenko 2007-05-14 16:28:20 UTC
Indeed it was a regression introduced by #107330.
Comment 4 mikhail.voytenko 2007-06-06 16:44:05 UTC
Please verify the issue.
Comment 5 michael.ruess 2007-06-12 08:38:24 UTC
*** Issue 78309 has been marked as a duplicate of this issue. ***
Comment 6 michael.ruess 2007-06-14 14:37:35 UTC
Verified fix in CWS mav21.
Comment 7 Mathias_Bauer 2007-07-04 10:05:19 UTC
*** Issue 78512 has been marked as a duplicate of this issue. ***
Comment 8 michael.ruess 2007-07-05 17:15:41 UTC
Checked fix in OO 2.3 milestone 680m219.