Issue 77652 - Find/Replace dialog does not remember the options
Summary: Find/Replace dialog does not remember the options
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.2.1 RC1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@framework
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2007-05-21 15:32 UTC by arysin
Modified: 2009-10-10 17:17 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description arysin 2007-05-21 15:32:55 UTC
Find/Replace dialog remembers entered text but does not remember the options
(and expanded state of the options pane). Thus if users does search for e.g.
[a-z] with Regular Expression flag, next time the dialog is opened the [a-z] is
restored but Regular Expression flag is cleared which does not make sense. More
than that the Options pane is not expanded so user has to expand it first, then
check "Regular Expressions" option and only then he/she can repeat the search.

Expected: the find dialog should remember all of the settings used at previous
search.
Comment 1 paul.m.nz 2007-05-23 03:14:10 UTC
Confirmed issue on win2000, OOo2.2.1RC1

Think it would be a good idea if the current state of the find/replace dialog
remembered the last settings (just as it does with the find/replace text)...
Comment 2 thorsten.martens 2007-07-04 10:43:19 UTC
TM->requirements: have a look
Comment 3 cno 2009-06-27 22:22:20 UTC
IMO it is worse (looking at 3.1.0 /DEV300m50):
regular expression flag remains, but Options part is hidden !
Comment 4 cno 2009-06-27 22:23:51 UTC
hmm, I would suggest this as a duplicate for issue 88714
Any objections ?
Comment 5 cno 2009-10-02 11:31:12 UTC
AFAIAA, "the find dialog should remember all of the settings used at previous
search" is working.
Related issue in 88714
Close this one as works for me.
Comment 6 Mechtilde 2009-10-10 17:17:09 UTC
worksforme -> closed