Issue 78098 - RPT: report header should be *before* page header, not after
Summary: RPT: report header should be *before* page header, not after
Status: CLOSED WONT_FIX
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: recent-trunk
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: ocke.janssen
QA Contact: issues@dba
URL:
Keywords: new_implementation
Depends on:
Blocks:
 
Reported: 2007-06-05 08:35 UTC by Frank Schönheit
Modified: 2013-08-07 15:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document to reproduce the bug case (216.36 KB, application/vnd.sun.xml.base)
2007-06-05 08:36 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2007-06-05 08:35:26 UTC
- open the attached database document
- open the report "countries, tabular" for editing
- note the order of sections:
  - report header
  - page header
  - detail section
  - page footer
  - report footer
- execute the report
- enter "Europe" in the parameter dialog
=> in the resulting document, the report header is positioned *after* the
   page header, which is certainly not expectation conformant
Comment 1 Frank Schönheit 2007-06-05 08:36:25 UTC
Created attachment 45643 [details]
document to reproduce the bug case
Comment 2 Frank Schönheit 2007-06-05 08:43:06 UTC
There are more arguments why the order should be "report header before page
header". One is that a certain competitive product, which does have a much
longer history in report designing that we have, does it this way.

More important (in my opinion):
The current behavior makes it difficult (up to impossible for average users,
IMO) to create a simple tabular report *with* report header. That is, a report
like the one in the attached document: On every page, there is some header
containing the field names, and the rest of the page is filled with the field
content in tabular form:
page 1:
    +-------------------------------+
    |          Report Header        |
    +-----------+---------+---------+
    |  Field 1  | Field 2 | Field 3 |
    +-----------+---------+---------+
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    +-----------+---------+---------+
page 2:
    +-----------+---------+---------+
    |  Field 1  | Field 2 | Field 3 |
    +-----------+---------+---------+
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    | data      | data    | data    |
    +-----------+---------+---------+

This layout is *possible* with our current behavior, but difficult: You need to
define a group, which is bound to some constant value (say "1"), and put the
table headings into the group header instead of the page header. In my opinion,
this is way too difficult for the average user, and a clumsy workaround only.

Also, I'd claim that such tabular reports, as sketched above, are a pretty
common use case.
Comment 3 Frank Schönheit 2007-06-05 08:43:56 UTC
This is a new implementation in CWS oj14. Adding keyword "new_implementation".
Comment 4 Frank Schönheit 2007-06-05 09:05:20 UTC
correcting version
Comment 5 Frank Schönheit 2007-06-05 11:30:58 UTC
The Report Designer iTeam decided that this is no show stopper for the first
release, and no "should be fixed if possible at all". targeting to "not
determined" for the moment.
Comment 6 ocke.janssen 2007-06-05 12:47:14 UTC
In the first way we change the ordering of page header and report header in the
following way

- page header
- report header
-detail
-report footer
-page footer

The reason here is that a page header always starts the page.
Comment 7 ocke.janssen 2007-10-15 08:33:12 UTC
I-Team decided to close this issue.
Comment 8 ocke.janssen 2007-10-15 08:34:04 UTC
.