Issue 78106 - wrong vertical align in report's data field
Summary: wrong vertical align in report's data field
Status: CONFIRMED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.2.1 RC2
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL: http://web89.server-drome.net/misc/wr...
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2007-06-05 11:09 UTC by jocaha
Modified: 2013-08-07 15:45 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
ODF 1.2 Base file with example reports (87.39 KB, application/vnd.sun.xml.base)
2008-06-04 18:50 UTC, drewjensen.inbox
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jocaha 2007-06-05 11:09:17 UTC
I have an adress database an do reports of it. My database contains day of birth.

For the beautifulness of the report, I make the colums as lang as the longest
data, but for one or two entries this is impossible because of the longness of
the data (e.g. Arthur-Miller-Street 1604 Backstreet Building). So The report of
that data goes over two lines. 

The day of birth in the same line and other column is displayed aligned on
bottom, which looks very awful, as you can see at the attached url on number 1
where I marked the row.

Editing the report and aligning the cells top does not help, because I need the
number format "data" for the day of birth. Otherwise an integer with the days
since Start-of-windows-aera (1/1/1980) is displayed.

Attached with the number format "data" is vertical align "bottom" which is
stronger than the cell's align :(

The same effect appears on one-line-rows if you know it as you can see at the
attached url on number 2 where I marked the row.
Comment 1 jocaha 2007-06-05 11:11:35 UTC
the described defect appears on star office 8 update 6
Comment 2 christoph.lukasiak 2007-09-03 14:21:16 UTC
may you attach a sample doc

thx
Comment 3 Mechtilde 2008-05-21 21:55:13 UTC
we don't need the URI twice

does the problem also exist in the latest version?
Comment 4 drewjensen.inbox 2008-06-04 18:49:18 UTC
Yes this is still a problem with 2.4.1 RC2 and 3.0 m_13

See attached ODF 1.2 base file.

The bug doc includes 2 Old_Style reports. 
qry_test_report_vertical_alingment and qry_test_report_vertical_alingment2

In qry_test_report_vertical_alingment2 I even modified the style
Tbl_Record_Content and selected a vertical text alignment of TOP but this does
not affect the outcome.

Comment 5 drewjensen.inbox 2008-06-04 18:50:28 UTC
Created attachment 54244 [details]
ODF 1.2 Base file with example reports
Comment 6 drewjensen.inbox 2008-06-04 18:51:33 UTC
assigning to developer and setting target of 3.x