Issue 78400 - Paragraph background color icon should remember and apply the last selected color
Summary: Paragraph background color icon should remember and apply the last selected c...
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOo 2.2
Hardware: All All
: P4 Trivial with 2 votes (vote)
Target Milestone: AOO PleaseHelp
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2007-06-13 15:53 UTC by georgeen
Modified: 2017-05-20 11:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

onMouseOver don´t show the arrow button (7.04 KB, image/jpeg)
2007-06-13 15:54 UTC, georgeen
no flags Details
movie showing behaviour as expected (544.96 KB, application/x-shockwave-flash)
2007-09-10 20:28 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description georgeen 2007-06-13 15:53:15 UTC

This is in general for all OOo UI, for instance, when I change the font color to
some text on Calc or Writer, with the tool button (on format bar) it works, but
when I select another text to do the same with the same color I have to
re-select again the color, because the button change its appeareance to the
selected text's color not maintaining the last selected color and if I wanna
change, then I push the button's right-arrow to re-select. This behavior is the
same for all toolbar buttons that have a right arrow, so the productivity is
less, we have to re-select and re-select, OO don´t maintain the last
characteristic (color, border, etc) always change to the characteristic of the
selected text or area.

In Calc the border tool button has a little arrow in its right side, but when I
try to push the arrow is the same as if I push the button, worst, when you pass
the cursor over that tool button the button and its arrow shows the border of
them as a one thing and not as two parts (button and its arrow as you can see
into the attached image), the same for background color in writer.

Comment 1 georgeen 2007-06-13 15:54:36 UTC
Created attachment 45880 [details]
onMouseOver don´t show the arrow button
Comment 2 michael.ruess 2007-08-16 14:59:24 UTC
MRU->ES: this is about our toolbar handling, please care about it, though it may
be framework...
Comment 3 Rainer Bielefeld 2007-09-10 20:27:12 UTC
I am a little worried. Expected behaviour of "Change text colour button (Writer): 

When I change the colour of some text (from black to green, for example), the
"new colour selection" should remain, and another marked text should be changed
to green again without necessity to select "green" again. 

I tried with 2.2.1, but it did not work as expected, I had to select my "new
colour green" every time again.

I tried with 2.0.2., and it DID work as expected, my "new colour selection"
remained valid for all further changes 8pls see my little movie).

But when I tried 2.2.1 again, to my surprise now it worked as in 2.0.2, the
behavior had changed to the behaviour of 2.0.2. Strange!

Comment 4 Rainer Bielefeld 2007-09-10 20:28:44 UTC
Created attachment 48148 [details]
movie showing behaviour as expected
Comment 5 Rainer Bielefeld 2007-09-11 21:17:25 UTC
Currently I am not sure, but may be I wrote some nonsense. I can not reproduce
the (reported) "problem" with the _character_ colour at all, may be I tested the
character _background_ with 2.2.1?
Comment 6 georgeen 2007-09-11 22:47:49 UTC
I observed now that the problem occur sometimes (I tried to capture an animation
to show the problem but unsuccessfully). The button at first hand open the color
palette (for font color or background color) after, the button works but
sometimes the last color is lost, then the button act like the arrow, opening
the color palette, this is more frecuent in background color button and in Calc
for border is always, the button act like arrow. So is a condition that when the
last color or selection is lost (return to the default value because I select
another area or do something) the button act like the arrow (a desired behavior
as I can see) but fail sometimes because lost the last selection, the problem is
after the selection. I work in OO 2.2.1 for Windows (Win XP SP2). If I can
capture an animation I'm going to send to you the movie with the strange
behaviour. Thanks
Comment 7 georgeen 2008-05-22 15:06:18 UTC
I'm testing OOo 3 beta, and the issue is present again but only in background
color of writer and font color and background color on Calc. I haven't test on
Draw and impress, but I suppose that they have the same problem. The behavior on
font text on writer is as I need so, when I wanna change the text color
I select the text and open the pallette and select the color I want then text is
 colored. If I select another or the same text, the last color is always present
and showed in the button (the line below icon on the tool button).

In the other color buttons it doesn't happens, always the indicator (the line
bellow the icon) change to the actual color value of the selected text, cell or
background, as is expected but for highlighting.

About the arrow in the right of that kind of tool buttons works as expected, if
no color or default it shows the palette, but if it has a colored text button
applies the color and the arrow shows the palette, of course this only happens
on txt color button on writer, because is the only one that works.

Please confirm the issue.
Comment 8 eric.savary 2008-09-11 08:48:07 UTC
After some tests I only see an inconsisteny in the Paragraph background color

Common behavior:
1. when no color as been changed, click on a color icon
2. the color palette shows up
3. choose a color
4. the chosen color appears on the icon
5. from now on, the palette won't appear with a simple click, the last color is
directly applied instead.

The paragraph background color button always bhaves 1-3.
At 4, it's not the last color but the current color at cursor which is shown.
At 5, the palette appears again like in 2.

Sum up: The paragraph background color icon should behave like 1.-5.
Comment 9 Marcus 2017-05-20 11:31:40 UTC
Reset assigne to the default "".