Issue 78647 - Highlight: 'no fill' button doesn't work correctly
Summary: Highlight: 'no fill' button doesn't work correctly
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.2
Hardware: All All
: P5 (lowest) Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 86451 94496 110294 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-06-19 08:43 UTC by jdpipe
Modified: 2017-05-20 11:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jdpipe 2007-06-19 08:43:17 UTC
I tried to un-highlight some text that was highlighted yellow. I had previously
done this using the toolbar button, so the main button was coloured grey to mean
'no fill'. But when I click the main button (not the drop-down part), the
highlighting is not removed. I find that I have to use the drop-down part if I
want highlighting to be removed correctly.

I have 'track changes' set to 'record' but not 'show' -- just in case that is
relevant.

Ubuntu 7.04, standard deb package of OOo 2.2.
Comment 1 michael.ruess 2007-06-19 12:03:39 UTC
Reassigned to ES.
Comment 2 eric.savary 2007-06-19 12:18:06 UTC
@OS:
- select a word
- click on "Highlighting"
-> the word is highlighted in yellow (default)
-> the Highlignting button is yellow
- open the color palette of highlighted
- click on "No fill"
-> the word is not highlighted anymore
-> the Highlignting button is grey (no fill)
- click again on the Highlighting button
-> the word becomes yellow -> bug

Though the icon is set to "No fill", clicking on it highlights to yellow. And
this is not a toggle button because any other click will still highlight yellow
Comment 3 razvizara 2008-02-04 16:22:23 UTC
Tried Configuration Windows XP and Linux
Build 2.3.0
I reproduced this bug. I tried this right after download the program. So I
didn’t change anything about ooffice after downloading it.

The steps above show you the bug, only it can get just a bit more simple. You do
not have to highlight anything to begin with. 
1.open the color palette of highlighted
- click on "No fill"
(the Highlighting button icon is gray -no fill)
2. click on the highlight button icon (so the paint cursor goes away)
3. select a word 
4. click on a highlight button (the icon)

This will highlight the word most likely in yellow, that’s if that was the last
color chosen.

I tried this test.

1. open the color palette of highlighting, and choose to highlight in black (or
any other color)
2. open the color palette again and choose no fill then click on the highlighted
button icon so the paint cursor disappears
3. now select a word
4. click on the highlighted button icon.

This time it will highlight the word in black (or whatever color you choose to
begin with) so it will go back to the last actual color chosen to highlight
rather than yellow each time. 
 
I tried to substitute “no fill” with many actual color (like pink), this did not
have any bug in it. The selected word would turn pink each time, rather than
black. So to work around this bug you should just highlight using the color of
the background (for most documents white) or open the highlight color palette
each time and click no fill. 

Also, I tried this with various background colors. When I choose no fill from
the color palette of highlight, it indeed unhighlights it, and I see the
background color, but when I press the highlight button icon, it again goes back
to the last color chosen for highlight rather than the background color. When I
then change the background to something else, the portions actually
unhighlighted by enter no fill from the color palette stay not filled, and
change with the background color, while the areas highlight by the bug stay
highlighted. 
Comment 4 jdpipe 2008-02-05 00:33:30 UTC
I can also confirm that the bug is still present in the standard Ubuntu 7.10
package for OpenOffice 2.3.0.
Comment 5 michael.ruess 2008-02-26 07:29:12 UTC
*** Issue 86451 has been marked as a duplicate of this issue. ***
Comment 6 michael.ruess 2008-10-01 08:51:34 UTC
*** Issue 94496 has been marked as a duplicate of this issue. ***
Comment 7 measdale 2009-01-28 16:38:34 UTC
Can confirm that this bug still exists in 3.0.0m9 on Windows (various).

Surely should be at least P4 - a button on the default Formatting toolbar which
doesn't function as defined? Highlighting is pretty common functionality -
people keep registering it, since at least v. 1.1 (issues 19603, 21480, etc.).

Might need "highlight" in the summary, so users can find it and vote for it?
Comment 8 eric.savary 2010-03-22 15:52:01 UTC
*** Issue 110294 has been marked as a duplicate of this issue. ***
Comment 9 Marcus 2017-05-20 11:27:25 UTC
Reset assigne to the default "issues@openoffice.apache.org".