Issue 78858 - Display PS-OpenType fonts on UNX platforms
Summary: Display PS-OpenType fonts on UNX platforms
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 2.2.1
Hardware: All Unix, all
: P3 Trivial with 29 votes (vote)
Target Milestone: OOo 3.2
Assignee: eric.savary
QA Contact: issues@gsl
URL:
Keywords:
: 85977 (view as issue list)
Depends on:
Blocks: 43029
  Show dependency tree
 
Reported: 2007-06-25 14:25 UTC by hdu@apache.org
Modified: 2017-05-20 10:23 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2007-06-25 14:25:26 UTC
This issue is a split of issue 43029: Just displaying or measuring text which uses PS-Opentype fonts is 
much easier than being able to print or PDF-export them.
Comment 1 hdu@apache.org 2007-06-25 14:26:12 UTC
accepted
Comment 2 silverex 2007-07-06 10:15:43 UTC
It's really important to get these fonts working. Many professional fonts are 
now distributed in PS-OTF format, including majority of Adobe fonts. Being 
unable to use them on UNX OOo prevents us from using Linux.
Comment 3 hdu@apache.org 2007-08-07 09:51:56 UTC
PS-OpenType support for display and layouting are implemented now in CWS otf01.
Comment 4 tehmul 2007-09-21 06:15:17 UTC
Do we really have to wait for OOo 3.0 for this patch to land? I was hoping it
would be part of OOo 2.3. It's a pain to fire up VMware everytime we need to
work with a document containing OTFs.
Comment 5 mbayer 2008-01-14 23:11:43 UTC
I'm afraid adding the ability to display, but not to print certain fonts, won't
make OOo win any usability awards.
Thus, issue 43029 needs to be implemented without further procrastination.
Comment 6 ousia 2008-05-16 18:45:53 UTC
I have many OTF fonts installed on my Linux system and OOo_3-beta seems not to
be able to display them.

Hasn't this been already fixed?

Thanks,


Pablo
Comment 7 mbayer 2008-05-17 00:58:48 UTC
mbayer->ousia: As you can see in the EIS, CWS otf01, which covers this issue,
has not yet been integrated. For further inquiries, please contact the
dev@qa.openoffice.org mailing list.
Comment 8 hdu@apache.org 2008-07-24 14:23:01 UTC
Retarget: Doesn't make sense to integrate it when it cannot be printed or exported.
Comment 9 xavier_robin 2008-12-11 16:22:50 UTC
I disagree with last comment by hdu. In Impress you often don't need to export /
print your document, just display it on screen / beamer. In this case it might
already be useful to use PS-OO fonts. Also it would help if, like me, you switch
between Windows and Linux and your files get all scrambled because the font
isn't recognized on one of your systems. Even if it isn't 100% functional, it
would already be an improvement.
Comment 10 tommy27 2009-02-11 06:09:18 UTC
i agree with robin.
if it's already fixed why wait till september 2009?
Comment 11 hdu@apache.org 2009-08-19 14:58:18 UTC
@es: please verify in CWS otf01
Comment 12 eric.savary 2009-08-20 13:40:53 UTC
Hi!

I am QA Representative for the the CWS otf01.
We decided make this CWS install sets public in order for every one to check the
fix *before* integration.

Install sets can be found here:
ftp://qa-upload.services.openoffice.org/otf01

Please give your feedback.
Try to see if something is broken. Bugs which already existed before the CWS
shouldn't be discussed here. Please write new issues for them.
Features or further implementation should also be handled in separated issue.

Thank you!
Comment 13 eric.savary 2009-08-21 16:03:22 UTC
Tested on Solaris and Linux: OTF fonts like Humboldt Fraktur display fine.

Verified in CWS otf01
Comment 14 aynadamar 2009-09-02 19:43:35 UTC
@es

I'm running Ubuntu 9.04 x86_64 and I own some commercial OTF fonts I can test.

If you could build a x86_64 build that'd be really appreciated

Thanks in advance and keep up the great quality :-)
Comment 15 hdu@apache.org 2009-09-03 08:45:44 UTC
@aynadamar: DEV300_m57 which will soon be available from http://download.openoffice.org/next/ will 
have the support for PS-OTF and the build will be available for all platforms as usual.
Comment 16 aynadamar 2009-09-07 23:29:20 UTC
I've tested m57 on Ubuntu 9.04 x86_64 and work as expected with the fonts I own.

I've still an important question:

Will be added a tab to "character style" like "Available OpenType features"? (I
couldn't find anything alike)

Something like a checkbox object list where activate ordn, onum, liga, etc.
opentype features.
Comment 17 hdu@apache.org 2009-09-08 07:52:48 UTC
>Will be added a tab to "character style" like "Available OpenType features"? (I couldn't find anything alike)
>
> Something like a checkbox object list where activate ordn, onum, liga, etc. opentype features.

See issue 16032 and 79878 for tracking the progress of defining this user interface. Both tasks are 
assigned to the user-experience team.
Comment 18 hdu@apache.org 2010-05-19 08:00:35 UTC
*** Issue 85977 has been marked as a duplicate of this issue. ***