Issue 79125 - With Java disabled, repetitive popup.
Summary: With Java disabled, repetitive popup.
Status: CLOSED DUPLICATE of issue 76385
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.2
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: orcmid
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-03 03:48 UTC by datakid
Modified: 2017-05-20 10:11 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
this is the file in question. (99.50 KB, text/plain)
2007-07-03 03:52 UTC, datakid
no flags Details
pic of error message and data loss (254.96 KB, image/jpeg)
2015-02-20 05:52 UTC, Chris F
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description datakid 2007-07-03 03:48:50 UTC
I've got ubuntu feisty installed and OO2.2

I increased the RAM available and disabled JRE so as to get quick start times.

I was sent a Word Document that only contained an image.

I right clicked on the image to see it in greater detail, and chose "picture"
from the drop down menu. (I don't know if this is the correct procedure, but I
was experimenting)

When the picture window popped up I got the following error:

OpenOffice.org requires a Java runtime environment (JRE) to perform this task.
However, use of a JRE has been disabled. Do you want to enable the use of a JRE now?
[Yes][No][Cancel]

The issue is that if you hit No or Cancel with the mouse, the error message just
reappears, continuously.

I've just got rid of it using shift-N (capital N, which is underlined in the
popup's No button)

Good luck,
Comment 1 datakid 2007-07-03 03:52:14 UTC
Created attachment 46461 [details]
this is the file in question.
Comment 2 michael.ruess 2007-07-03 07:19:34 UTC
MRU->JSK: I guess, this is due to the "Macro" tab in the picture dialog, right?
Should happen on Frame and Object properties dialog.
Comment 3 joerg.skottke 2008-01-07 13:02:03 UTC
*** Issue 80912 has been marked as a duplicate of this issue. ***
Comment 4 joerg.skottke 2008-01-07 13:02:19 UTC
*** Issue 80878 has been marked as a duplicate of this issue. ***
Comment 5 kpalagin 2008-01-31 08:21:41 UTC
Confirming with 2.4m2431 on WinXP - as described.
Comment 6 arthurarchnix 2008-03-13 10:47:24 UTC
I'd like to confirm that this issue is still present in Ooo 2.3 on Ubuntu Gutsy.

Description of Problem: When working in OooWriter without a JRE enabled and
editing a frame, if you click on the macro tab you'll be notified that you need
to enabled a JRE to use this feature, and be prompted to either enable it, not
enable it, or cancel. Clicking anything but 'OK' or 'Enable it' simply results
in another prompt. It is not possible to escape from this loop except by
accepting the prompt to enable JRE. Much more seriously, if you do not have java
integration installed (openoffice.org-java-common) it is not possible at all to
escape this loop. You must kill the Ooo process to end the loop, possibly losing
any work you have open and not saved.

Steps to reproduce: (1) Under options, choose not to use a JRE. Close Ooo,
restart and open a new writer document. Create a frame. Right-click on the frame
and edit. Switch to the macro tab. (2) Uninstall openoffice.org-java-common
(also removes base), repeat steps in one above
Comment 7 joerg.skottke 2008-06-17 10:13:40 UTC
Also in 3.0 beta and later. This is probably duplicate to quite a number of
other issues.

To jl.
Comment 8 joachim.lingner 2008-06-17 10:40:14 UTC
.
Comment 9 ipsnicerous 2010-09-08 06:58:42 UTC
This is still an issue with Ubuntu 10.04 and OOo 3.2 when openoffice.org-java-
common is not installed.
Comment 10 Chris F 2015-02-20 05:52:03 UTC
Created attachment 84517 [details]
pic of error message and data loss

As of today, this issues still exists in version 4.1.

It occurred before I saved data, so there was data-loss associated with it.

I'm running Win 7 [no Java RT] on a HP Pavilion laptop.
Comment 11 orcmid 2015-02-20 06:23:40 UTC
(In reply to Chris F from comment #10)
> Created attachment 84517 [details]
> pic of error message and data loss
> 
> As of today, this issues still exists in version 4.1.
> 
> It occurred before I saved data, so there was data-loss associated with it.

OK Chris.

These are not all reports of the same defect -- there are several different messages with regard to use of a JRE.

I am taking this incident, but I may not be in a position to do the fix.  What will be done is work up documentation of these messages and how they arise and what to do about them.

That some are essentially no-exit crashers is particularly disturbing.

We'll have to isolate the different cases and their causes and break down what can be repaired where.  The no-way-out cases are obviously the primary ones.

I hope I can get back to you and the other incident-reporters here so that we can isolate as many cases where there is no way out as we can and determine the different ways they are triggered.
Comment 12 Chris F 2015-02-20 18:52:56 UTC
(In reply to orcmid from comment #11)
> (In reply to Chris F from comment #10)
> > Created attachment 84517 [details]
> > pic of error message and data loss
> > 
> > As of today, this issues still exists in version 4.1.
> > 
> > It occurred before I saved data, so there was data-loss associated with it.
> 
> OK Chris.
> 
> These are not all reports of the same defect -- there are several different
> messages with regard to use of a JRE.
> 
> I am taking this incident, but I may not be in a position to do the fix. 
> What will be done is work up documentation of these messages and how they
> arise and what to do about them.
> 
> That some are essentially no-exit crashers is particularly disturbing.
> 
> We'll have to isolate the different cases and their causes and break down
> what can be repaired where.  The no-way-out cases are obviously the primary
> ones.
> 
> I hope I can get back to you and the other incident-reporters here so that
> we can isolate as many cases where there is no way out as we can and
> determine the different ways they are triggered.

Thanks orcmid. Appreciate the help. Putting error reports in the wrong category is a common issue with self-reporting systems. ':-/
Comment 13 oooforum (fr) 2016-06-13 08:46:40 UTC
.

*** This issue has been marked as a duplicate of issue 76385 ***