Issue 79367 - Template Java file missing
Summary: Template Java file missing
Alias: None
Product: App Dev
Classification: Unclassified
Component: sdk (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: Other Linux, all
: P3 Trivial
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2007-07-08 15:17 UTC by finngruwierlarsen
Modified: 2017-05-20 09:32 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description finngruwierlarsen 2007-07-08 15:17:21 UTC
My platform is Ubuntu 7.04 (Feisty). I use the OOo 2.2 and the SDK 2.2 packages
that both comes with the distro. I use the version of Netbeans 5.5.1 for Linux
that comes in a bundle with JDK 1.6.0.

After installing the OOo Netbeans integration, I wanted to make an Add-on. So I started with completing the wizard. The wizard
created two files in Default Package, Addons.xcu and ProtocolHandler.xcu. All
fine - but where should my Java code go?? I tried making a small Java file, but
when I tried to deploy the oxt, it failed. I tried in many different ways, but
the same thing happened. At last, after spending a whole day with this, I found
this description of a Java template file that apparently should have been
generated in my project:

After copying and pasting the Java code into a new file (and manually removing
all the lines numbers), I was finally able to create an oxt that would actually

The conclusion is, that for some reason the template Java file never shows up. I
have tried the same thing on another machine with the same software setup - same
Comment 1 steffen.grund 2007-07-09 08:13:11 UTC
Accepted. But seems to be a Ubuntu problem, perhaps with the installation of
OpenOffice and SDK.
Comment 2 steffen.grund 2007-07-30 14:26:16 UTC
set a target.
Comment 3 stan22 2007-08-16 11:50:33 UTC
i have the same problem on windows xp, nb 5.5.1, staroffice 8, sdk 2.2

the java source file wasn't created correctly, i found the file in <nb install
dir>/bin where it was named as a tempfile and also folder structure
"<mymodulename>src\org\openoffice" was created there.
after moving and renaming the java source file i was able to compile the plugin
Comment 4 stan22 2007-08-16 12:26:26 UTC
update - it works fine with openoffice 2.2.1 (i also installed it into a path
without spaces just in case)
Comment 5 malte_timmermann 2007-08-16 19:12:37 UTC
mt->sg: Since you are currently working on a new version of the NB plugin,
please make sure that version also works with StarOffice...
Comment 6 Carl Marcum 2016-04-06 23:18:24 UTC
Obsolete version