Issue 79586 - unwanted substitution of ITC fonts by a completely unrelated font family
Summary: unwanted substitution of ITC fonts by a completely unrelated font family
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.2
Hardware: PC Linux, all
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2007-07-13 12:42 UTC by unixtowindowstolinux
Modified: 2017-05-20 11:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
5 files - 2 fonts and one example ODT text file (242.45 KB, application/x-gzip)
2007-07-13 13:08 UTC, unixtowindowstolinux
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description unixtowindowstolinux 2007-07-13 12:42:01 UTC
on a fresh ubuntu 7.04 installation, i installed a type1 font, Adobe's ITC Stone
Serif. the font showed up in OOo Writer's font pull-down menu, but it was
rendered using a completely unrelated, sans-serif font (i hadn't specified any
font substitutions). any text that i formatted as Stone Serif came out looking
like it was set in the "Saab" font.

on examination of the font files, i found:

FontName StoneSerif
FullName ITC Stone Serif
FamilyName ITC Stone Serif

what shows up in OOo Writer's font pulldown menu is "Stone Serif" (with a
space), which is not identical to any of the above strings.

i installed the fontforge package and used it to remove the "ITC" from the
FamilyName field, installed the modified font, and this cured the problem.

i tried a few fonts, and observed that the problem occurs with fonts whose name
starts with ITC, and doesn't occur with fonts that don't have ITC in their
names. i only tried a few so i can't say for sure exactly what it is about the
name that causes the problem, but i know at least that changing "ITC Stone
Serif" to "Stone Serif" fixes the problem.

since the ITC Stone Serif is not freely distributable, i have made a couple of
test fonts, derived from the Century Schoolbook L font that comes with ubuntu.
they are identical to Century Schoolbook L, except that the name has been
changed to BlahDeBlah, and the UID is the randomly-generated value, 4150396.

i am attaching several files:

    original.afm, original.pfb - font named "ITC BlahDeBlah"
    workaround.afm, workaround.pfb - font named "BlahDeBlah"
    blah.odt - small example text file containing 3 lines of text

i'm not sure how widespread this problem is, but i know that, at least, it is
reproducible on a fresh installation of ubuntu 7.04.

to reproduce the problem:

(1) copy original.afm and original.pfb to your ~/.fonts directory.

(2) open blah.odt in OOo Writer. the middle line, formatted in the BlahDeBlah
font, should look identical to the top line, formatted in Century Schoolbook L,
but it doesn't. instead, it looks like the bottom line, which is formatted in
the Saab font. notice that BlahDeBlah shows up in the pulldown font menu, but it
is also rendered wrong there.

(3) close OOo Writer.

(4) remove original.afm and original.pfb from ~/.fonts

(5) copy workaround.afm and workaround.pfb to ~/.fonts

(6) open blah.odt again in OOo Writer. now the middle line looks like the top
line, as it should, and BlahDeBlah in the font pulldown menu looks right.

this is exactly analogous to the process i went thru with ITC Stone Serif.

although i haven't tried many fonts, i expect this problem to be pretty
widespread among people who depend on professional-level fonts. for an expert,
it's a troublesome problem, and for a new linux user who depended on these
fonts, it would be a complete showstopper.
Comment 1 unixtowindowstolinux 2007-07-13 13:08:12 UTC
Created attachment 46753 [details]
5 files - 2 fonts and one example ODT text file
Comment 2 michael.ruess 2007-07-13 13:54:28 UTC
reassigned to ES.
Comment 3 Regina Henschel 2007-07-13 14:45:13 UTC
It seems, that your problem has already been discussed in issue 28610. Please
have a look.
Comment 4 unixtowindowstolinux 2007-07-13 19:58:44 UTC
i don't think this is a dup of issue 28610.

i believe that issue is about OOo making different choices on different
platforms about whether to apply heuristics to a given font name to map into a
canonical form. issue 28610 would result in a document produced on one system
looking wrong in a different system. but any given font on any given machine
would look and act properly on that machine.

with the problem i'm addressing here in this issue, i can take a perfectly good
font, install it in my system, and it is completely unusable. it renders a
completely unrelated font, not some font that is another vendor's implementation
of the font i'm trying to use.
Comment 5 eric.savary 2008-09-12 19:49:18 UTC
Can you please check if the current version has solved your problem?
http://download.openoffice.org/680/?intcmp=1235
Thank you!
Comment 6 eric.savary 2008-09-17 16:13:13 UTC
Answering my own question: yes, still in current version.
Comment 7 hdu@apache.org 2008-10-20 14:00:31 UTC
Wat is the result of
  fc-match "ITC Stone Serif"
on that particular system?
Comment 8 Marcus 2017-05-20 11:18:00 UTC
Reset assigne to the default "issues@openoffice.apache.org".