Issue 79665 - Please add support for language variants to the rsc compiler
Summary: Please add support for language variants to the rsc compiler
Status: CLOSED FIXED
Alias: None
Product: Internationalization
Classification: Code
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: ivo.hinkelmann
QA Contact: issues@l10n
URL:
Keywords:
: 66919 (view as issue list)
Depends on: 79666
Blocks: 56622
  Show dependency tree
 
Reported: 2007-07-16 15:02 UTC by ivo.hinkelmann
Modified: 2013-08-07 15:01 UTC (History)
1 user (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ivo.hinkelmann 2007-07-16 15:02:46 UTC
Please add support for language variants to the rsc compiler. Language variants
are for example like "en-US-ooo" or "pt-BR-so" . Please use the fallback routine
provided by eike thus pt-BR-so fallsback to pt-BR and not en-US. Language
variants are needed for issue 56622
Comment 1 ivo.hinkelmann 2007-07-16 15:41:03 UTC
set target to OOo 2.4
Comment 2 philipp.lohmann 2007-11-05 17:21:22 UTC
implemented in CWS rsclangvar, however Eike's fallback routine identifies e.g.
"pt-BR" as fallback for itself, so I have not used it.

implemented fallback is now "a-b-c" -> "a-b" -> "a" -> "en-US" with the
exception of "x-no-translate" (an "en-US" itself)

Incidentally this would also solve the  "en-UK" fallback case which seems to
have failed in tools's GetIsoFallback
Comment 3 philipp.lohmann 2007-11-05 17:22:02 UTC
please verify in CWS rsclangvar
Comment 4 ivo.hinkelmann 2007-11-12 10:24:26 UTC
looks fine!
Comment 5 ivo.hinkelmann 2008-02-20 12:54:32 UTC
*** Issue 66919 has been marked as a duplicate of this issue. ***
Comment 6 thorsten.ziehm 2009-07-20 15:20:26 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues