Issue 79682 - WW8: Loop opening DOC containing many/large tables
Summary: WW8: Loop opening DOC containing many/large tables
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.2.1
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
Keywords: regression
Depends on:
Reported: 2007-07-17 07:44 UTC by januszzz
Modified: 2013-08-07 14:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

File which hangs OO 2.2.1 (323.00 KB, application/msword)
2007-07-17 07:49 UTC, januszzz
no flags Details
XML file from MS Word 2003 which hang OO 2.2.1 (607.14 KB, text/xml)
2007-07-17 07:51 UTC, januszzz
no flags Details
repaired bugdoc (374.50 KB, application/msword)
2007-07-17 11:59 UTC, frank.meies
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description januszzz 2007-07-17 07:44:41 UTC

as in subject - OO crashes on some doc or xml. There is no easy way to
reproduce, but I include docs that halts it.

I created a doc file using Microsoft Word 97, then moved it to her Gentoo
machine and used it for a while. Although it still was doc, OO handled it perfectly.

Yesterday I closed the file, and OO did not manage to open it again.So I opened
it in MS, saved as doc again. Still OO hangs. OK, I've saved it as Microsoft
Word XML - and the same, OO hangs. So I saved it as RTF - ok, OO opens it.

Additionaly I tried Google Apps to open the doc - without luck, but I'm newbie
(& was on hurry) on Google Apps so I may have missed sth.

I suspect saving/opening?

I tried OO 32/64 bit versions - Gentoo standard ebuild and compiled by me, as
well as 32 bit Windows Version.

this is serious - I had to use Microsoft. Without it I would lost my document.
OO was completely unusable (I know, I had MS binary format, but later I got also
an XML!!)

If you got any further questions please do not hesitate contacting me, I will
try to provide any feedback.


ps. Howto attach a file?
Comment 1 januszzz 2007-07-17 07:49:10 UTC
Created attachment 46850 [details]
File which hangs OO 2.2.1
Comment 2 januszzz 2007-07-17 07:51:46 UTC
Created attachment 46851 [details]
XML file from MS Word 2003 which hang OO 2.2.1
Comment 3 januszzz 2007-07-17 07:53:46 UTC
Files attached.
Comment 4 michael.ruess 2007-07-17 10:22:35 UTC
MRU->FME: open attached doc -> loop
the document contains many large tables (~30 pages).
Comment 5 frank.meies 2007-07-17 11:58:51 UTC
fme->januszzz: Row 26-81 of the last table in this document have their height
set to "exactly 0.01cm". This makes Writer choke. I'll attach a 'fixed' version
of your bugdoc.
Comment 6 frank.meies 2007-07-17 11:59:54 UTC
Created attachment 46858 [details]
repaired bugdoc
Comment 7 januszzz 2007-07-17 12:27:30 UTC
Fine, it works, although I'm not sure if I ever touched rows height. And MS 
handles the doc perfectly, so I guess Writer has some issues with that. 


Comment 8 frank.meies 2007-09-05 09:02:13 UTC
Loop does not occur anymore due to the implementation of some general loop
controls in the Writer layout engine, see issue 81146.
Comment 9 januszzz 2007-09-05 09:55:27 UTC
I do not understand ? :-)

In which version this bug will be RESOLVED? target milestone 2.4? As long as I 
know my 2.2.1 still hangs on the doc & xml?
Comment 10 frank.meies 2007-09-05 10:09:03 UTC
fme->januszzz: This has been fixed in cws loopcontrol. This cws is targeted for
OOo 2.4 and not yet integrated. You can check the state of this cws here:
Comment 11 januszzz 2007-09-05 10:16:25 UTC
OK, no more questions, THANKS!
Comment 12 frank.meies 2007-09-10 13:38:17 UTC
fme->mru: Ready for QA.
Comment 13 michael.ruess 2007-09-18 09:17:21 UTC
Verified in CWS loopcontrol.
Comment 14 michael.ruess 2007-10-31 12:35:48 UTC
Checked fix in SRC680m235 build.