Issue 79854 - Excel roundtrip: #MACRO? error for internal Calc functions unknown to Excel
Summary: Excel roundtrip: #MACRO? error for internal Calc functions unknown to Excel
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: kla
QA Contact: issues@sc
URL:
Keywords: needhelp, oooqa
: 99075 (view as issue list)
Depends on:
Blocks: 111112
  Show dependency tree
 
Reported: 2007-07-21 05:04 UTC by yurysita
Modified: 2013-08-07 15:14 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
task scheduled (868.50 KB, text/html)
2007-07-21 05:10 UTC, yurysita
no flags Details
WHen you edit cell with #MACRO?, e.g. H3 by removing and adding finall bracket you will get rid of #MACRO? error (106.00 KB, application/vnd.ms-excel)
2008-08-07 14:49 UTC, pawel_marzec
no flags Details
all ODF functions unknown by Excel (9.67 KB, application/vnd.ms-excel)
2010-01-18 14:16 UTC, daniel.rentz
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description yurysita 2007-07-21 05:04:33 UTC
I am working with OpenOffice.orgCal for first time; and in every cell where I 
have a nested formula working with today and some satar time, i get this label 
#MACRO? each time I open the file.
Comment 1 yurysita 2007-07-21 05:10:30 UTC
Created attachment 46958 [details]
task scheduled
Comment 2 frank 2007-07-21 12:04:13 UTC
In no way a P1 Issue, lowered to P3
Comment 3 frank 2007-07-23 10:49:49 UTC
Hi,

not a bug but an enhancement request. Calc does not know all the translations
for AddIn functions from Excel. DIAS is one of these functions.

Frank
Comment 4 pawel_marzec 2008-08-07 14:30:17 UTC
I have got the same problem and I find it very annoying. I have to edit a
formula (e.g. delete and add a final bracket) to make it work again after
opening saved spreadsheet.
Comment 5 pawel_marzec 2008-08-07 14:49:13 UTC
Created attachment 55635 [details]
WHen you edit cell with #MACRO?, e.g. H3 by removing and adding finall bracket you will get rid of #MACRO? error
Comment 6 Regina Henschel 2009-02-10 22:34:29 UTC
*** Issue 99075 has been marked as a duplicate of this issue. ***
Comment 7 nickhibma 2009-10-07 10:03:44 UTC
This has been an issue for several years now (Google reveals mention of this problem in 2005).

Could someone just add the missing functions (WEEKNUM for one)?

Thanks.
Comment 8 daniel.rentz 2009-11-05 08:35:21 UTC
Changed the behaviour as following:

When saving a spreadsheet to the XLS format, every function "F" that Excel does
not understand will be written as "_xlfnodf.F". This is similar to what Excel
does with its own additional functions, e.g. it writes "_xlfn.BAHTTEXT" for the
BAHTTEXT function. When reading these documents, all "_xlfnodf.*" functions will
be converted back to the Calc internal functions.

XLS files written with previous versions (up to OOo 3.2) do not contain this
function syntax. Therefore, while importing, the "DAYS" function contained in
the attached documents is not recognized. The reason is that the function name
is written with its localized UI name, e.g. "DAYS" in one document, and "DÍAZ"
in the other.
Comment 9 daniel.rentz 2009-11-05 08:42:14 UTC
The following functions are handled this way (listed by ODF function name):
ARABIC, B, BASE, CHISQDIST, CHISQINV, COMBINA, DAYS, DECIMAL, FDIST, FINV,
FORMULA, GAMMA, GAUSS, ISFORMULA, ISOWEEKNUM, MUNIT, NUMBERVALUE, PDURATION,
PERMUTATIONA, PHI, RRI, SHEET, SHEETS, UNICHAR, UNICODE.
Comment 10 Rainer Bielefeld 2010-01-18 05:34:46 UTC
What's the exact state of this issue?
Comment 11 daniel.rentz 2010-01-18 09:08:25 UTC
The related CWS is on its way into QA
Comment 12 daniel.rentz 2010-01-18 14:16:51 UTC
Created attachment 67266 [details]
all ODF functions unknown by Excel
Comment 13 daniel.rentz 2010-01-18 14:17:49 UTC
dr->oc: load attached ODS document, save to XLS format (Excel 97-2003), reaload.
All functions must reappear.
Comment 14 oc 2010-03-05 17:49:41 UTC
verified in internal build cws_dr74
Comment 15 daniel.rentz 2010-10-21 18:13:09 UTC
Sorry to tell, but this fix is broken again due to another bugfix.
Comment 16 daniel.rentz 2010-10-21 18:13:36 UTC
change owner
Comment 17 daniel.rentz 2010-10-22 13:11:21 UTC
fixed in CWS OOO330/calc33stopper1
Comment 18 daniel.rentz 2010-10-22 16:59:02 UTC
back to QA
Comment 19 kla 2010-10-25 09:54:44 UTC
Seen ok in cws calc33stopper1 -> verified
Comment 20 kla 2011-04-01 07:29:58 UTC
Seen ok into the master -> closed