Issue 80186 - Modifying and deleting styles disabled
Summary: Modifying and deleting styles disabled
Status: CLOSED DUPLICATE of issue 4679
Alias: None
Product: Calc
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.2.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-30 18:16 UTC by deaconctk
Modified: 2007-07-30 19:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description deaconctk 2007-07-30 18:16:27 UTC
If any sheet in a spreadsheet is protected, no styles can be modified or deleted
(although new styles can be created).  Note that the options to modify or delete
a style are not disabled--they just do nothing when selected.  As far as I can
tell, this behavior is not documented at all.

At a minimum, an error dialog should be displayed indicating that one or more
sheets are protected thereby blocking modifications and deletions.  Tool tips
could also be used to provide the same info

This has been an issue for me for over a year--just not critical enough that I
took the time to research it online.  (I suspect most users never get around to
researching issues online.)  I could not find this documented in any bugs, but
did find it reported twice in the past month in the forums
(http://www.oooforum.org/forum/viewtopic.phtml?t=59322 and
http://www.oooforum.org/forum/viewtopic.phtml?t=60267).
Comment 1 frank 2007-07-30 19:55:40 UTC
double to Issue 4679

*** This issue has been marked as a duplicate of 4679 ***
Comment 2 frank 2007-07-30 19:56:00 UTC
closed double