Issue 80264 - attached document crash when saved as .ppt
Summary: attached document crash when saved as .ppt
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: save-export (show other issues)
Version: 680m222
Hardware: PC (x86_64) Linux, all
: P3 Trivial (vote)
Target Milestone: OOo 2.3
Assignee: kendy
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-01 16:11 UTC by hub
Modified: 2009-07-20 15:16 UTC (History)
2 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
crasher document (167.50 KB, application/vnd.ms-powerpoint)
2007-08-01 16:12 UTC, hub
no flags Details
patch to fix the problem (1.36 KB, patch)
2007-08-01 18:28 UTC, hub
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description hub 2007-08-01 16:11:21 UTC
Open the attached PPT document in Impress.

File->Save As... under a different name but still as PPT
Click "Yes" to confirm you want to save it as PPT.

Impress crashes

here is the stack trace:

(gdb) where
#0  0x00002b2ef2f41b95 in raise () from /lib64/libc.so.6
#1  0x00002b2ef2f42f90 in abort () from /lib64/libc.so.6
#2  0x00002b2ef2b6dd24 in __gnu_cxx::__verbose_terminate_handler () from
/home/hub/OOinstall/vanilla/program/libstdc++.so.6
#3  0x00002b2ef2b6be56 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libstdc++.so.6
#4  0x00002b2ef2b6be83 in std::terminate () from
/home/hub/OOinstall/vanilla/program/libstdc++.so.6
#5  0x00002b2ef2b6bf6a in __cxa_throw () from
/home/hub/OOinstall/vanilla/program/libstdc++.so.6
#6  0x0000000000448a80 in ?? ()
#7  0x0000000000448a97 in operator new[] ()
#8  0x00002aaaac39b47a in X11SalBitmap::ImplCreateDIB () from
/home/hub/OOinstall/vanilla/program/libvclplug_gen680lx.so
#9  0x00002aaaac39b5c7 in X11SalBitmap::Create () from
/home/hub/OOinstall/vanilla/program/libvclplug_gen680lx.so
#10 0x00002b2ef036b160 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libvcl680lx.so
#11 0x00002b2ef032877c in Bitmap::Bitmap () from
/home/hub/OOinstall/vanilla/program/libvcl680lx.so
#12 0x00002b2ef0331174 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libvcl680lx.so
#13 0x00002b2ef0332529 in Bitmap::Scale () from
/home/hub/OOinstall/vanilla/program/libvcl680lx.so
#14 0x00002b2ef033d377 in BitmapEx::Scale () from
/home/hub/OOinstall/vanilla/program/libvcl680lx.so
#15 0x00002aaabc3945bd in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libemp680lx.so
#16 0x00002aaabc395017 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libemp680lx.so
#17 0x00002aaabc381814 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libemp680lx.so
#18 0x00002aaabc38f7a3 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libemp680lx.so
#19 0x00002aaabc385647 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libemp680lx.so
#20 0x00002aaabc3860b5 in ExportPPT () from
/home/hub/OOinstall/vanilla/program/libemp680lx.so
#21 0x00002aaab6397357 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsd680lx.so
#22 0x00002aaab62e2773 in sd::DrawDocShell::ConvertTo () from
/home/hub/OOinstall/vanilla/program/libsd680lx.so
#23 0x00002aaab22271cf in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#24 0x00002aaab222a01d in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#25 0x00002aaab222a78d in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#26 0x00002aaab223155f in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#27 0x00002aaab22758e8 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#28 0x00002aaab2281b66 in SfxBaseModel::storeAsURL () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#29 0x00002aaab2293516 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#30 0x00002aaab2232bef in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#31 0x00002aaab22e8f50 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#32 0x00002aaab22dd164 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#33 0x00002aaab230604a in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#34 0x00002aaab23069b9 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libsfx680lx.so
#35 0x00002aaab2daa5b0 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libfwk680lx.so
#36 0x00002b2ef048f9b6 in Menu::Select () from
/home/hub/OOinstall/vanilla/program/libvcl680lx.so
#37 0x00002b2ef048b5f5 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libvcl680lx.so
#38 0x00002b2ef04f0b11 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libvcl680lx.so
#39 0x00002aaaac3c3ad6 in SalDisplay::DispatchInternalEvent () from
/home/hub/OOinstall/vanilla/program/libvclplug_gen680lx.so
#40 0x00002aaaaab2d509 in Window::RequestHelp () from
/home/hub/OOinstall/vanilla/program/libvclplug_gtk680lx.so
#41 0x00002aaaac1f0484 in g_main_context_dispatch () from
/opt/gnome/lib64/libglib-2.0.so.0
#42 0x00002aaaac1f32b5 in g_main_context_iterate () from
/opt/gnome/lib64/libglib-2.0.so.0
Comment 1 hub 2007-08-01 16:12:04 UTC
Created attachment 47253 [details]
crasher document
Comment 2 hub 2007-08-01 18:28:54 UTC
Created attachment 47255 [details]
patch to fix the problem
Comment 3 hub 2007-08-01 18:32:05 UTC
The attached patch fix the problem which end up being a 64-bits issue.

Basically Size as defined in util/tools/inc/tools/gen.hxx:228 is using long for
its members. But the awt::Size that is extracted for the Any type is using
32-bits value. The code was just casting pointers. The patch does the conversion
by extracting the awt::Size first, then assigning the members directly.

The crash was caused by the Size value being too large.... (garbage + 32bits of
value in a 64bits long)

patch against m220 in the sd module.
Comment 4 kendy 2007-08-01 18:35:56 UTC
Issue type: PATCH
Comment 5 kendy 2007-08-01 20:01:45 UTC
Committed to CWS kendy18.
Comment 6 kendy 2007-08-01 20:02:21 UTC
thb: As agreed on IRC, please verify :-)
Comment 7 thb 2007-08-02 09:33:21 UTC
Still works in the 32bit version, reviewed patch -> ok

@kendy: could you please verify this yourself, don't have access to a x86_64
version, currently.
Comment 8 kendy 2007-08-02 10:00:07 UTC
I confirm the problem on x86-64, and that the patch fixes that => VERIFIED.
Comment 9 thorsten.ziehm 2009-07-20 15:16:36 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues