Issue 80491 - Writer freezes when editing document
Summary: Writer freezes when editing document
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.2.1
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-09 02:48 UTC by robertf
Modified: 2017-05-20 11:17 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description robertf 2007-08-09 02:48:26 UTC
I was editing a biggish (35 pages, 4.3 MB) document, with track changes and show
changes. While making changes on p. 25, Writer froze, CPU bound. Killing and
restarting led to the same behaviour.

That was with version 2.0 under Linux. Then with 2.2 under Windows XP, exactly
the same symptoms. Also with the latest 2.3 snapshot under XP.

I tried turning off show changes but it didn't help.

I tried making somewhat different changes, in either of the 2 paragraphs on that
page, but it always freezes after I've added a bit of text. How long it stays
alive does depend on exactly where I insert new text in that paragraph. It does
seem to be reproducible.

When I opened the original unedited document and continued with my editing from
the paragraphs in question, it worked fine.

I've tried to simplify and also obfuscate the document, but it's hard to find
things to do that don't make the bug disappear. Deleting all the images (using
the navigator) and replacing all e's by x's did preserve the bug, as did
removing certain text, but other similar changes made the bug go away.

I don't mind sharing the document with some developers, but I don't really want
it to be public (it's a draft of a chapter of a student's thesis). Is it
possible to submit a file by e-mail to someone?
Comment 1 michael.ruess 2007-08-09 09:09:09 UTC
please attach the offending document to this issue, so that we can reproduce and
fix the problem here. You can also send the document directly
(mru@openoffice.org) for the case it contains confidential data.
Comment 2 robertf 2007-08-09 11:40:58 UTC
The document has been sent directly by e-mail.
Comment 3 michael.ruess 2007-08-09 13:40:22 UTC
MRU->OD: open the document, travel to page 25 and enter a paragraph break -> loop.
On the pages 26 ff there are many VERY large frame. When I delete the content
preceeding page 25, the size of the frames decreases significantly and the loop
won't occur anymore.
Comment 4 robertf 2007-08-09 13:57:05 UTC
FWIW, in trying to reduce the size of the test document, I found that deleting
some content (e.g., text within paragraphs) near the beginning of the document
would cause the bug to disappear, but deleting other, similar content would
leave the bug intact. Also, some single-character find-replace-all operations
(e.g., e -> x) left the bug intact but others (e.g., a -> y, IIRC) caused it to
disappear.
Comment 5 Oliver-Rainer Wittmann 2007-08-09 14:39:13 UTC
set target back to OOo 2.x
Comment 6 Mathias_Bauer 2007-12-03 14:47:45 UTC
according to release status meeting -> 3.x
Comment 7 Marcus 2017-05-20 11:17:59 UTC
Reset assigne to the default "issues@openoffice.apache.org".