Issue 80779 - First Custom Animation on a slide always wrong
Summary: First Custom Animation on a slide always wrong
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: 680m225
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: OOo 2.3
Assignee: christian.guenther
QA Contact: issues@graphics
URL:
Keywords: oooqa, regression
Depends on:
Blocks: 80294
  Show dependency tree
 
Reported: 2007-08-17 12:15 UTC by jorgepereira
Modified: 2007-11-21 15:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
One slide with 3 picures showing wrong custom animation on first one. (10.80 KB, application/vnd.sun.xml.impress)
2007-08-17 12:17 UTC, jorgepereira
no flags Details
start with 1 Click (11.41 KB, application/vnd.oasis.opendocument.presentation)
2007-08-17 17:53 UTC, Regina Henschel
no flags Details
Fix (907 bytes, patch)
2007-08-30 11:23 UTC, thb
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description jorgepereira 2007-08-17 12:15:26 UTC
I create a simple blank slide and insert more than one picture.
Then I add a Custom Animation to each picture (Exit -> Dissolve).
Then I change each animation from "On click" to "After Previous".
When I play the presentation, the first picture immediatly disappears. Other
pictures dissolve correctly after that.
I tried with simple non-transparent gif and jpeg pictures.
When I do the same in Powerpoint 2003 (Exit -> Dissolve Out) it works as
expected, but if I open it with Impress it doesn't (and I also have to click
once to start the animation).
I have this problem with OOG680m1_Win32Intel (en_US) and also with 680m225 and
one or two builds before that. Java is Sun JRE 1.6u2.
If I find a way I'll attach a small file.
Comment 1 jorgepereira 2007-08-17 12:17:14 UTC
Created attachment 47591 [details]
One slide with 3 picures showing wrong custom animation on first one.
Comment 2 Regina Henschel 2007-08-17 16:13:12 UTC
I don't see a defect. You set, that the animation starts after the previous.
When there is no previous, it starts immediately. It does what you set. If you
want the first animation to start with a click, you must set "Start on Click"
for the first animation.
Comment 3 jorgepereira 2007-08-17 17:17:34 UTC
OK, I accept this behaveour (Openoffice starting immediately unlike Powerpoint).
But then the first custom animation should dissolve like the subsequent
pictures, at the same pace. But I never had a chance to see the firs picture, it
seems to start already "dissolved" then it proceeds to the second picture and
then (and only then) it behaves as I would expect, dissolving it.

So I changed the file I sent, and the first custom animation now "start on
click, very slow" (the other 2 stay "after previous, very slow"). The
presentation starts, I see all pictures (as expected) then right after I click
the first picture disappears (does not dissolves very slow as defined... just
disappears and fast). Then, after a while, presentation proceeds as expected and
the second picture dissolves, and so on.
Comment 4 Regina Henschel 2007-08-17 17:53:06 UTC
Created attachment 47612 [details]
start with 1 Click
Comment 5 Regina Henschel 2007-08-17 17:55:29 UTC
Is is indeed defect in 680m255 and in OOGm1. It works as expected in OOo2.2.1.

You see the defect, if you compare the behavior in OOo2.2.1 and in OOGm1. Start
the presentation, click once. The picture vanish immediately instead of dissolve.
Comment 6 christian.guenther 2007-08-20 11:10:27 UTC
I can reproduce the bug.
showstopper because it is broken in src680m225
Please have a look.
Comment 7 clippka 2007-08-22 09:41:01 UTC
The effect seems to play for the correct amount of time but there is nothing
visible.

from my observation this only affects images. And only the first image that has
an exit effect. F.e. having two images animated and the first one has an
entrance effect it is visible, the second effect then is invisible.

cl->thb: I have no idea, you have to take over
Comment 8 thb 2007-08-26 21:53:45 UTC
ok
Comment 9 thb 2007-08-30 01:19:23 UTC
Happens on all platforms. Happens only for graphic-only objects, and solely for
exit effects. Does not show up on dxcanvas, nor cairocanvas. Seems that vcl
canvas gets the mask for the sprites wrong - but no idea yet why.
Comment 10 thb 2007-08-30 11:23:35 UTC
Created attachment 47878 [details]
Fix
Comment 11 thb 2007-08-30 11:25:28 UTC
Grmbll - cached repaint of graphics did not render to mask outdev, therefore,
sprite was fully transparent. Attached fix.
Comment 12 thb 2007-08-30 12:51:28 UTC
@cgu: fixed in CWS thbpp8d. please verify.
Comment 13 philipp.lohmann 2007-08-30 13:00:55 UTC
reviewed
Comment 14 christian.guenther 2007-08-30 14:50:42 UTC
CGU: Verified in cws thbpp8d
Comment 15 christian.guenther 2007-11-21 15:56:23 UTC
CGU: integrated in src680m236 and oog680m9