Issue 8084 - Strip attachments from posts to lists
Summary: Strip attachments from posts to lists
Status: CLOSED FIXED
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Mailing lists (show other issues)
Version: current
Hardware: Other Other OS
: P3 Trivial with 5 votes (vote)
Target Milestone: ---
Assignee: lsuarezpotts
QA Contact: issues@www
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-10-06 09:39 UTC by mdekkers
Modified: 2004-11-05 11:16 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
mime-types to be stripped (2.43 KB, text/plain)
2002-10-31 13:24 UTC, stx123
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mdekkers 2002-10-06 09:39:12 UTC
The current situation where all mail sent to the lists have to be moderated is 
simply farcical. EZMLM supports stripping of attachments, and implementation 
of this is trivial. Please don't come up with stuff like the "next version of 
sourcecast", since it will just make you look silly, and not on the ball when 
it comes to meeting your client's requirements. For now, I don't think your 
focus should be on nice integration with SC or anything like that, but to just 
get a list of allowed mimetypes implemented. niceties can come later.
Comment 1 Unknown 2002-10-11 10:02:35 UTC
+1

Axel Bojer
Comment 2 stx123 2002-10-15 20:14:05 UTC
reassigning to support.
Comment 3 Unknown 2002-10-15 23:24:28 UTC
Can someone edify me as to where the quote "next version of
sourcecast" originated?  This sounds like an offshoot of a prior issue
or at least a prior conversation.  Can that be referenced here so we
have the entire picture?  The detail provided here is sketchy at best,
especially for a p1 issue.

We need more detail to proceed here.  Is the issue regarding an
automatic stripping of all attachments from all messages?  Are there
some rules or logic involved in determining what should attachments be
deleted?  What is farcical about moderating a message?  It is a very
common and real option that mailing list admins choose to use.
Comment 4 Unknown 2002-10-16 00:41:35 UTC
cc'ing myself
Comment 5 Martin Hollmichel 2002-10-17 18:06:16 UTC
I think the reference is 6607.
Comment 6 Unknown 2002-10-17 18:35:11 UTC
closing as a duplicate

*** This issue has been marked as a duplicate of 6607 ***
Comment 7 stx123 2002-10-17 18:54:07 UTC
Brian, simply changing state to resolved/duplicate to 6607 seems not
appropriate  to me. 6607 is in state resolved/later (truckee).
We should have one issue, that makes clear, that we don't have to wait
for another SC release, but work is ongoing.
Please either
a) reopen this issue 8084 or
b) reopen 6607
Thanks, Stefan.
Comment 8 Unknown 2002-10-17 23:47:34 UTC
Stefan - I closed this issue as a duplicate because it had very little
substance in it.  It ranted some about a prior issue, but gave us no
specific information on exactly what to work on or the prior issue number.

There is much more to consider than the simple "stripping of
attachments" mentioned above.  Issue 6607, if that really is the issue
being referenced by Martijn, does not simply ask for all attachments
to be stripped, but for a means to configure "filtering rules for
mailing lists in general".  The proper way to accomplish this goal is
to create a section in the sourcecast UI (per user, per message size)
which enables this.  This is _not_ trivial.  

I can justify my closing this as a duplicate given Martin's entry that
this is in response to 6607 and given our prior understanding that
issues addressed in future releases would be closed with a status of
resolved/later.  

I would be happy to reopen the issue but I'm not sure I understand
your statement "work is ongoing".  Is this to be considered an
enhancement request that you would like to have processed prior to a
new release of sourcecast?  If so, we need much more detail than what
has been provided here.  E.g. should all attachments be stripped from
all emails in all mailing lists?  Is it done by mime-type or by size?
 By user or by mailing list?  Do you want a user-interface for this or
would editing configuration files directly be acceptable?  Or is there
some combination of these suggestions that would make the most sense?
Comment 9 stx123 2002-10-31 13:21:26 UTC
Brian,
I would like to use this issue for tracking the ongoing work in the 
currently used SC version. Let's use #6607 for the enhancement 
request for future version.
I initiated through Eric, that attachment stripping is done based on 
mime-types (not size). The configuration would have no UI. The list 
of to be stripped mime-types is attached.
We agreed, that we will use discuss@ooo as the first test. This seems 
to work now.
Let's take users@ for the next test. Please update, when users@ is 
configured as discuss@ to strip attachments.
Thanks, Stefan
Comment 10 stx123 2002-10-31 13:24:39 UTC
Created attachment 3441 [details]
mime-types to be stripped
Comment 11 Unknown 2002-10-31 17:58:28 UTC
are the top 8 mime types to be ignored because they have pound signs
in front of them?

# application/text
# application/x-gtar
# application/x-gzip
# application/x-shar
# application/x-tar
# application/x-zip-compressed
# application/zip
# message/rfc822
Comment 12 stx123 2002-10-31 18:42:02 UTC
Yes, ignore these entries.
This allows text, compressed files and mails to be attached.
BTW, this file should contain the mime-types you already used for the
discuss@ test. Are there any differences?
Thanks, Stefan.
Comment 13 lsuarezpotts 2002-11-05 23:42:33 UTC
hi,
We have added the mimeremove to:
*discuss@ooo
*users@ooo
*dev@ooo
*webmasters@ooo

These are the most trafficked.
I am now going to request that the native-lang lists also benefit from
this, and will ask the incubator projects if they want this, too.
louis
Comment 14 garyfreder 2002-11-10 13:23:49 UTC
Please add *@groupware.openoffice.org to the list.

Thanks

Gary
Comment 15 lsuarezpotts 2002-11-14 07:51:24 UTC
Gary, will do.
futher update:
requested all the native-lang lists, and all project issues, cvs
lists, sparing dev@ lists.
We can also add announce lists, later.
louis 
Comment 16 stx123 2002-11-14 09:04:47 UTC
Louis, please leave features@<project>, interface-announce@ooo,
interface-discuss@ooo also out.
Greetings
Stefan
Comment 17 stx123 2002-11-14 18:29:16 UTC
I didn't see, that the issue has been assigned to me :-)
Louis, is there anything, that I can do for further handling?
Reassigning to Louis.
Comment 18 lsuarezpotts 2002-11-14 21:20:03 UTC
hi, Stefan,
No, nothing for you to do.
Right now I just have to process the PCN issue.
best,
louis
Comment 19 lsuarezpotts 2002-11-19 02:17:40 UTC
all stipulated lists have had the filter put in place (and I don't see
why we cannot add more lists as necessary).
closing.
louis 
Comment 20 michael.bemmer 2003-03-16 20:22:22 UTC
As agreed with Louis, we can close all the resolved fixed issues he owns.
Comment 21 michael.bemmer 2003-03-16 20:27:42 UTC
As agreed with Louis, we can close all the resolved fixed issues he owns.
Comment 22 stx123 2004-11-05 11:16:59 UTC
Changing the title allows better retrieval...