Issue 80936 - Romanian È™ and È› diactitics aren't recognised as correct
Summary: Romanian È™ and È› diactitics aren't recognised as correct
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: issues@lingucomponent
QA Contact: issues@lingucomponent
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-22 13:34 UTC by luciangrijincu
Modified: 2013-02-24 20:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description luciangrijincu 2007-08-22 13:34:05 UTC
There is a misunderstanding regarding the form of the correct Romanian diacritics:
ș, Ș, ț, Ț are often replaced with the incorrect: ş, Ş, ţ, Ţ (notice that the
correct diacritics have a comma underneath, not a cedilla as in the case of the
incorrect ones).
For more details on this issue see http://secarica.ro/html/s-uri_si_t-uri.html
or https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/108057

I use Ubuntu 7.04's Open Office 2.2.0-1ubuntu4, I'm not sure how to map this to
standard Open Office versions, but the issue (IMHO) is from the dictionary.

Steps to reproduce:
1. Create a new document and from 
  Right click -> Edit paragraph style -> Font Tab -> Language
  select Romanian (make sure to have the dictionary installed - visual cue: 
  an icon with the text "ABC" and a check mark on it on the left of the word 
  "Romanian".
2. Inset the word "fața" (notice the comma underneath the letter "t")
3. Notice that the spell checker has marked the word as being incorrect and 
  offers as "correct" alternatives the words: "fata" and "faţa" (the last one 
  has an incorrect cedilla underneath).

Expected behavior:
The spell checker should accept the word "fața" (with a comma underneath) as the
correct form, and correct cedilla based words to their comma versions.
Comment 1 troodon 2008-03-22 16:13:00 UTC
Confirming this with 2.4 RC6 running on Windows Vista and 2.2 on Ubuntu 7.04. As
more and more romanian users will switch to Windows Vista and Linux
distributions with the new standard keyboard layouts, this issue will become
more and more serious.
Comment 2 nemeth.lacko 2008-03-23 19:32:24 UTC
Supporting correct acuted letters is a simple conversion of the dictionary files
and using UTF-8 encoding in them. We could do it, but I suggest to inform the
maintainer of the Romanian dictionary before.
Comment 3 lconstantin 2008-12-06 21:53:17 UTC
Romanian dictionaries distributed as extension today do not have the problem
described above. The problem was fixed a long time ago.
Comment 4 lconstantin 2008-12-06 21:54:00 UTC
Romanian dictionaries distributed as extension today do not have the problem
described above. The problem was fixed a long time ago.
Comment 5 nemeth.lacko 2008-12-07 00:08:10 UTC
From OOo 3.1 you can use the new ICONV affix feature for optional character
handling, too. Example:

  # Accepting de facto replacements of the Romanian comma acuted letters
  SET UTF-8
  ICONV 4
  ICONV ÅŸ È™
  ICONV ţ ț
  ICONV Ş Ș
  ICONV Ţ Ț



Comment 7 nemeth.lacko 2008-12-07 00:16:35 UTC
Closed.