Issue 81082 - Loosing digital signature of macros after storing document
Summary: Loosing digital signature of macros after storing document
Status: CLOSED DUPLICATE of issue 85306
Alias: None
Product: App Dev
Classification: Unclassified
Component: api (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P3 Trivial
Target Milestone: ---
Assignee: joachim.lingner
QA Contact: issues@api
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-28 12:04 UTC by benzman1981
Modified: 2013-02-24 21:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The sample document with a signature for macros (9.01 KB, application/vnd.oasis.opendocument.text)
2007-08-28 12:05 UTC, benzman1981
no flags Details
The java snippet to reproduce the behavior (2.35 KB, text/plain)
2007-08-28 12:06 UTC, benzman1981
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description benzman1981 2007-08-28 12:04:30 UTC
Hallo,
when I load a writer document with the component loader that contains a digital 
signature for macros and store this document after I change something, then the 
digital signature gets lost.
I will attach a snippet and a document with a signature to reproduce the 
behavior.

Regards,
Markus
Comment 1 benzman1981 2007-08-28 12:05:42 UTC
Created attachment 47821 [details]
The sample document with a signature for macros
Comment 2 benzman1981 2007-08-28 12:06:34 UTC
Created attachment 47822 [details]
The java snippet to reproduce the behavior
Comment 3 jsc 2007-08-28 12:19:17 UTC
that is exactly the concept and principal of digital signatures. When you change
something the signature gets lost. You have to sign the document again after any
kind of changes on the document.
Comment 4 jsc 2007-08-28 12:20:19 UTC
invalid -> closed
Comment 5 benzman1981 2007-08-28 12:49:38 UTC
Well then how do You sign the document afterward through the API? I would have 
tried this, but I could not found any snippets for this.

Regards,
Markus
Comment 6 benzman1981 2007-08-28 14:18:33 UTC
After some research and after a hint of one of our customers the concept You 
mentioned is correct for signing the document itself. This is why the 
OpenOffice.org application gives the user a hint that all document signatures 
will be removed if it is change. So far so good. But the concept You stated 
does not seem to be correct for signing macros. If I change a document that 
hase signed macros with the OpenOffice.org application and save it again, then 
all signatures for macros are still available. If I do this through the UNO API 
then the signatures are lost. This is inconsistent as either both, the 
OpenOffice.org application and the UNO API, should remove the signatures for 
the macros after saving a changed document, or both should not touch the 
signatures and leave them in the document.

Regards,
Markus
Comment 7 jsc 2007-08-28 15:46:55 UTC
i agree that the behaviour should be the same and assign the issue to the
responsible engineer 
Comment 8 joachim.lingner 2007-08-28 16:18:08 UTC
Do you have some test code available which uses the API? If yes, could you
attach it to this issue?
Comment 9 benzman1981 2007-08-28 16:21:24 UTC
Have a look at the attachments. There is a java snippet 
MacroSignatureExample.java.
Comment 10 benzman1981 2007-08-28 16:22:23 UTC
What behavior for the signatures for macros will be choosen? Will the API be 
changed so that the signatures for macros will not be lost after saving through 
the API, or will the OpenOffice.org application be changed, so that the 
signatures for macros will be removed after saving?
If the API will no be changed and the signatures will be lost after saving, how 
is it possible to set the signature again afterwards through the API?
Comment 11 joachim.lingner 2007-12-07 15:01:44 UTC
Retargeted to 3.0
Comment 12 joachim.lingner 2008-05-30 15:16:33 UTC
Retargeting.
Comment 13 joachim.lingner 2008-06-23 12:48:05 UTC
Saving the document may not break the macro signature.

*** This issue has been marked as a duplicate of 85308 ***
Comment 14 joachim.lingner 2008-06-23 12:52:52 UTC
Wrong duplicate
Comment 15 joachim.lingner 2008-06-23 12:53:31 UTC
.

*** This issue has been marked as a duplicate of 85306 ***
Comment 16 joachim.lingner 2008-06-23 12:56:41 UTC
.