Issue 81282 - "Preview in Webbrowser" uses wrong browser
Summary: "Preview in Webbrowser" uses wrong browser
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.3.0 RC1
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2007-09-05 10:43 UTC by parity
Modified: 2013-02-07 22:00 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description parity 2007-09-05 10:43:16 UTC
The new feature "Preview in webbrowser" uses the wrong browser.

I tried the feature using Debian Linux 4.0 with KDE and GNOME. I set the default
browser in /etc/alternatives to "iceweasel". In the KDE and GNOME settings (as
normal user) I set the default browser also to "iceweasel". uses
epiphany (in GNOME) and konqueror (in KDE) and I cannot change it. There is no
option in to change it and both are not the default browsers.
This is a definitely a wrong behaviour.

There are two possibilities to solve this issue:
1. An option for setting the webbrowser uses. This option could
be placed in "Tools --> Options --> Internet --> Browser" because there is also
the option to define the default e-mail program.
2. Use the default x-www-browser from /etc/alternatives.

I think choice 1 would be the best.
Comment 1 bitsfritz 2007-09-05 12:34:11 UTC

here with not typical configuration:
- kubuntu breezy batcher
- kde applications driven out of windowmaker (ubuntu <-> asus kernel issues)
- nativ mozilla firefox /home installation for easy update puroses
- OOo 2.3 rc1 debs build by sun

"webbrowswer preview" aka "Vorschau in Webbrowser" works as expected:
mozilla firefox shows preview - konqueror stays sleeping in the cave :o))

Comment 2 thorsten.martens 2007-09-05 12:38:27 UTC
TM->SBA: please have a look, thanks !
Comment 3 adept 2008-01-26 22:02:35 UTC
In Ubuntu 7.10 (Gnome) with OO 2.3.1 Pro (Infra) it is all right.
Default browser - firefox.
Comment 4 pmike 2008-01-27 08:03:13 UTC
Confirmed on Kubuntu 7.10 + Seamonkey
I've registered .html file extension and Web-browser "default application" to
Mozilla Seamonkey
Local .html files clicked from file manager opens in SM.
But OOo (2.3.0-Ubuntu and 2.3.1) launches Konqueror instead.
Comment 5 kpalagin 2008-01-27 10:17:10 UTC
Confirming as per pmike.
Comment 6 carsten.driesner 2008-01-28 13:11:08 UTC
cd->obr: Looks like a problem with the SystemShellExecute service?
Comment 7 nospam4obr 2008-01-28 13:19:57 UTC
OOo passes the URL to gnome-open / kfmclient. Did you configure your preferred
web browser in the desktop settings ?
Comment 8 pmike 2008-01-29 18:27:33 UTC
Yes, I did. In Kubuntu 7.10: K - System Settings - Default Application - Web
Also, in Konqueror Settings, I've registered .html extension to Seamonkey.
No luck either.
Comment 9 nospam4obr 2008-01-29 21:09:50 UTC
I believe the configuration of bitsfritz worked because OOo did not detect a KDE

There are actually two problems here:

1) The security fix which introduced proper shell quoting broke the desktop
specific -open-url invocation for paths containing any to-be-escaped characters
 (because an access(.. ,X_OK) is done on an already escaped file name).

2) kfmclient aka konquorer always opens local files (file://) directly, only
http urls & co are passed to the default browser. But as the underlying UNO
service is named "SystemShellExecute" and not "SystemBrowser", this behavior is
perfectly valid (for that service implementation, not for the feature).

So I add my preferred solution to the number of options above:

3. Create a dedicated url handler UNO service with the option to force the url
to be opened in the browser (or mail client). 
Comment 10 stefan.baltzer 2008-09-16 12:12:21 UTC
SBA->TM: Please proceed, thx.
Comment 11 parity 2008-10-05 15:27:19 UTC
OpenOffice 3.0RC3 uses the correct browser (Debian Lenny).

Was this issue fixed?
Comment 12 nospam4obr 2008-10-06 05:49:14 UTC
Maybe the fix for Issue 88440 makes this feature works more reliable, but I still think it works "by luck".