Issue 81299 - Copy Table from one database to another crashes
Summary: Copy Table from one database to another crashes
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.3.0 RC1
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 2.3
Assignee: marc.neumann
QA Contact: issues@dba
Keywords: oooqa, regression, release_blocker
Depends on:
Blocks: 80294
  Show dependency tree
Reported: 2007-09-05 16:58 UTC by Mechtilde
Modified: 2007-09-17 21:04 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Mechtilde 2007-09-05 16:58:32 UTC
Open two base documents

Choose Tables in both documents

copy a table from one database to the other. ("Kopieren -> Inhalte einfügen")


Thomas Krumbein found it under Windows Vista

I can confirm it under Debian 

I send two crah reports today.
It's r62ynn and rvdynn.
Comment 1 Mechtilde 2007-09-05 17:08:08 UTC
A simple Insert works

"content insert2 crashes 
Comment 2 christoph.lukasiak 2007-09-05 17:29:13 UTC
i can repro that like described in a OOg680m3 (also m2) with 'paste special'
insted of 'paste' (einfügen) - worked fine in a 8pp7
Comment 3 christoph.lukasiak 2007-09-05 17:30:29 UTC
set keyword 'regression'
Comment 4 Mechtilde 2007-09-05 17:34:57 UTC
OO 2.2.1 works, OOG680_m3=RC1 crashed, SRC680_m226 crashed,
Comment 5 Mechtilde 2007-09-05 17:51:24 UTC
SRC680_m222 also crashed
Comment 6 Frank Schönheit 2007-09-06 06:17:42 UTC
Please let's be realistic about the priority.
Comment 7 Frank Schönheit 2007-09-06 06:29:53 UTC
That's a regression of the ResMgr change - seems there still are res ids without
resource manager, somewhere in so3.
Comment 8 Frank Schönheit 2007-09-06 06:36:24 UTC
fs->pl: This probably came in with rev. 1.23 of so3/source/dialog/pastedlg.cxx.
In line 570, *SOAPP->GetResMgr() is accessed, which is NULL, unfortunately.
Any idea about this code, what SOAPP is, and why its res mgr is NULL at this place?
Comment 9 Frank Schönheit 2007-09-06 06:43:13 UTC
Great. SOAPP is defined as
DoDll has a member pResMgr, which is returned by GetResMgr, but *never* set to
anything other than NULL.
Comment 10 Frank Schönheit 2007-09-06 06:43:58 UTC
Phillip, since you did the res mgr change, you probably have the best idea which
res mgr should be used instead of SOAPP->GetResMgr?
Comment 11 Frank Schönheit 2007-09-06 06:49:41 UTC
  ResMgr * SoDll::GetResMgr()
    // Resourcen sind im Default ResMgr ( OFA )
    return NULL;

Hmm. How to access the OFA resources from within so? Also, why does SO3 build
own resources (so680<locale>.res) if they're not used?
Comment 12 Frank Schönheit 2007-09-06 06:58:57 UTC
Looking through other code in so3 which does resource access (and thus would
also crash), it seems this project is a collection of dead corpses. All
resource-dependent classes I found so far are not used *anywhere*, according to
LXR. Argh. Completely independent from this issue, I think I'm going to create a
CWS which will clean up so3.
Comment 13 ocke.janssen 2007-09-06 07:11:35 UTC
I already did some work in dbaccess in source/ui/app/AppController.cxx where I
replaced the dialog from so3 by the same dialog from svx, yes it's duplicate
code here, with only some more changes like ResMgr :-( I fixed it while fixing
issue i78257.

cvs diff -r1.42.14.3 -r1.42.14.4 AppController.cxx
Comment 14 ocke.janssen 2007-09-06 07:20:04 UTC
Grabbing this issue.
Comment 15 Frank Schönheit 2007-09-06 07:38:00 UTC
submitted issue 81309 for cleaning up so3.
Comment 16 ocke.janssen 2007-09-06 08:17:29 UTC
Fixed in cws dba23f
Comment 17 ocke.janssen 2007-09-06 09:01:24 UTC
Please verify. Thanks.
Comment 18 marc.neumann 2007-09-06 11:10:06 UTC
verified on Linux, windows is still building
Comment 19 marc.neumann 2007-09-06 14:09:16 UTC
verified also on windows
Comment 20 marc.neumann 2007-09-06 14:10:40 UTC
set target to 2.3
Comment 21 rene 2007-09-06 14:28:21 UTC
according to discussion in #oooreleases today:

12:45 < _Nesshof_> I also tend not to include this in release, not that much
                   users would are impacted and release would delay after OOoCon
12:46 < _Nesshof_> maybe we can offer dll/library separatly for those running
                   in that issue
12:47 < paveljanik> _Nesshof_: IE. releasing m4 as final and upload the
                    affected lib(s) from m5, right?
12:49 < _Nesshof_> yep
14:32 < paveljanik> but as it asks, I think that we do not even need to provide
14:32 < paveljanik> just fix it in 2.3.1.
Comment 22 andreschnabel 2007-09-08 10:56:10 UTC
just to mention, that the bug is more genereal. The crash seems to occure on any
attempt to "Insert special" on Base table screen. E.g. copy a Table from any
HTML Website, Insert - Special in Base -> crash
Comment 23 pavel 2007-09-10 15:30:03 UTC
Change target as agreed on releases meeting.
Comment 24 Mechtilde 2007-09-11 13:39:54 UTC
verified in OOG680_m5  -> closed