Issue 81503 - Automatic (dark) background color cannot be gotten rid of in Draw
Summary: Automatic (dark) background color cannot be gotten rid of in Draw
Status: CLOSED DUPLICATE of issue 75613
Alias: None
Product: Draw
Classification: Application
Component: ui (show other issues)
Version: OOo 2.2.1
Hardware: PC Linux, all
: P2 Trivial (vote)
Target Milestone: ---
Assignee: christian.guenther
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-11 14:13 UTC by tpesonen
Modified: 2008-06-13 10:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot (106.92 KB, text/plain)
2007-10-12 13:53 UTC, wolframgarten
no flags Details
Setting colours (139.97 KB, image/jpeg)
2008-01-31 01:48 UTC, tpesonen
no flags Details
The document after having set the colours in options (146.80 KB, image/jpeg)
2008-01-31 01:49 UTC, tpesonen
no flags Details
Setting a fill colour for the rectangle (75.47 KB, image/jpeg)
2008-01-31 01:51 UTC, tpesonen
no flags Details
The rectangle fill colour has been set, but nothing changed. (146.61 KB, image/jpeg)
2008-01-31 01:53 UTC, tpesonen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tpesonen 2007-09-11 14:13:47 UTC
The issues is exactly as 75613 (which affects Impress).

Description adopted to Draw from the aforementioned bug report.

Found on KDE/Linux.

OOo 2.1 and 2.2 now adopt colours from the desktop and assigns them as automatic
colours. If I want to get rid of this colour scheme and have my documents
displayed with their "true" colours, I need to alter them in
Tools->Options->Appearance. I can get my Writer docs to show with the normal
white background and black text this way.

The problem now is that on Draw, the document/drawing still uses the
desktop-inherited background colour, and the colour set in Options -> Appearance
is not respected. The font/foreground colour is correctly changed to black as
set in the options, though. This results, on my system, black text/lines etc. on
dark background on draw documents. My desktop colour scheme is such that the
background is darkish and texts are of light colours. 

Based on my earlier bug reports dealing with this issue on OOo, the bug appears
for some people only with high contrast color schemes which use dark or black
background. On KDE, which I use, the bug is easy to reproduce by setting the
colour scheme to High contrast (with white on black), and starting OOo, creating
a new drawing, setting document colours in "Appearance" in options as stated
above (for example: background white; font black), and observing how only the
foreground colour is changed for the Draw document, while the background remains
black/dark.

If there's need for screencaptures, more detailed reproduction steps etc. please
let me know. This should be very trivial to reproduce, though.
Comment 1 wolframgarten 2007-10-12 13:53:25 UTC
Created attachment 48862 [details]
Screenshot
Comment 2 wolframgarten 2007-10-12 13:54:54 UTC
I tested this with version 2.3.0 on Suse. I could not reproduce the problem
though I am not sure if I followed your instruction correct.
Please have a look at the new version. If your problem is still there feel freee
to reopen the issue. Thanks.
Comment 3 wolframgarten 2007-10-12 13:55:18 UTC
Closed.
Comment 4 tpesonen 2008-01-31 01:45:36 UTC
Reopening:

Tested again on the latest openSUSE 2.3.1 version. Not fixed.

Adding screenshots to demonstrate the following steps:

1. Launched Draw -> Options -> Set foreground and background colour to black and
white, respectively.

2. Shows that document background is still inherited from the desktop. The
colour setting had no effect.

3. Inserted a rectange. Foreground colour is correctl black, not white. Setting
a fill colour.

4. The area colour now set. The rectangle's fill colour still unchanged.

This has been the case for all >= 2.1.0 versions. This is exactly whyt I still
use 2.0.x The same problem as shown here has been reported for other components,
too, and they have been confirmed (Writer, Impress). There is no difference
between SUSE-supplied and www.openoffice.org vanilla builds: They all behave the
same.
Comment 5 tpesonen 2008-01-31 01:48:10 UTC
Created attachment 51273 [details]
Setting colours
Comment 6 tpesonen 2008-01-31 01:49:11 UTC
Created attachment 51274 [details]
The document after having set the colours in options
Comment 7 tpesonen 2008-01-31 01:51:31 UTC
Created attachment 51275 [details]
Setting a fill colour for the rectangle
Comment 8 tpesonen 2008-01-31 01:53:19 UTC
Created attachment 51276 [details]
The rectangle fill colour has been set, but nothing changed.
Comment 9 tpesonen 2008-01-31 01:55:37 UTC
OK, I of course sent the images in wrong order: OptionsSet.jpg is after the
Options->Colors have been set, and FillColourSet is after the rectangle got its
fill colour / area colour. Anyhow, the order doesn't make any difference, as
nothing changes.
Comment 10 tpesonen 2008-01-31 02:02:51 UTC
wg's screenshot looks OK. This is definitely not what I get, as the screenshots
show. I'm now on openSUSE 10.3, KDE 3.5.8 is from the latest STABLE repository.
Comment 11 wolframgarten 2008-06-13 10:13:35 UTC
Duplicate.

*** This issue has been marked as a duplicate of 75613 ***
Comment 12 wolframgarten 2008-06-13 10:14:08 UTC
Closed.