Issue 81536 - Cannot open/save to webdav server with Mac OS X OOo
Summary: Cannot open/save to webdav server with Mac OS X OOo
Status: CLOSED FIXED
Alias: None
Product: porting
Classification: Code
Component: MacOSX (show other issues)
Version: 680m225
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: thorsten.martens
QA Contact: issues@porting
URL:
Keywords: oooqa
: 83527 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-09-12 22:39 UTC by shaunmcdonald131
Modified: 2009-05-04 09:27 UTC (History)
12 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Make webdav work on Mac OSX (2.52 KB, patch)
2008-07-28 21:10 UTC, ldubost
no flags Details | Diff
an earlier Apple-oriented report following a forced quit of OOo 3.0.0rc1 (289.61 KB, text/plain)
2008-09-10 17:14 UTC, Graham Perrin
no flags Details
a more recent Apple-oriented report following a forced quit of OOo 3.0.0rc1 (226.62 KB, text/plain)
2008-09-10 17:14 UTC, Graham Perrin
no flags Details
OpenOffice.org remained amongst the list of running _and responding_ applications _after_ a quit had been forced due to non-responsiveness (40.75 KB, text/plain)
2008-09-10 17:15 UTC, Graham Perrin
no flags Details
TextWranger also stopped responding after trying to save to the same WebDAV volume with which OOo was having difficulty (50.59 KB, text/plain)
2008-09-10 17:17 UTC, Graham Perrin
no flags Details
a through-the-Plone view of some OOo-related debris at the root of the WebDAV volume, where the saves were attempted (54.29 KB, text/plain)
2008-09-10 17:17 UTC, Graham Perrin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description shaunmcdonald131 2007-09-12 22:39:07 UTC
I am unable to open or save to a web dav server using maho's m225. This affects both X11 and aqua 
builds.

This will probably affect the 2.3 release too. (Not checked yet).
Comment 1 obrmac 2007-09-13 07:52:38 UTC
maho, what is the configure line you build with ? Does it say anything about neon (which is used for 
webdav) ?
Comment 2 eric_openoffice 2007-09-13 09:44:01 UTC
confirmed with OOG680_m5 aka OOo 2.3.0rc3 

Since this issue seems to effect all Mac OS X build regardless if they are Aqua
or X11 I also changed the summary to reflect this. 

Comment 3 nospam4obr 2007-09-13 09:45:23 UTC
cc'ing ucb maintainers.
Comment 4 eric.bachard 2007-09-13 15:10:39 UTC
TRying to save on an iDisk, we have two errors.

1) /Volume/mav_eric-Public/test1.odp  does not exist

2) General I/O output error


=> around #42 things are interesting, and compehelper and ucbhelper can have a role. 


The stack (between the two error messages (libucpdav1.dylib is built with debug=t option):

(gdb) bt
#0  0x90009bf7 in mach_msg_trap ()
#1  0x90009b58 in mach_msg ()
#2  0x9082e2b3 in CFRunLoopRunSpecific ()
#3  0x9082dace in CFRunLoopRunInMode ()
#4  0x92de98d8 in RunCurrentEventLoopInMode ()
#5  0x92de8fe2 in ReceiveNextEventCommon ()
#6  0x92eff97c in ReceiveNextEvent ()
#7  0x01248766 in SalGetDesktopEnvironment ()
#8  0x0101383b in Application::Yield ()
#9  0x01152c3d in Dialog::Execute ()
#10 0x183a37bc in GetVersionInfo ()
#11 0x183a8b33 in GetVersionInfo ()
#12 0x183aa61e in GetVersionInfo ()
#13 0x183ae046 in GetVersionInfo ()
#14 0x183ae264 in GetVersionInfo ()
#15 0x183b4419 in component_getFactory ()
#16 0x006823ef in non-virtual thunk to comphelper::OComponentProxyAggregation::getTypes() ()
#17 0x007321ec in ucbhelper::InterceptedInteraction::extractContinuation ()
#18 0x007323c8 in ucbhelper::InterceptedInteraction::extractContinuation ()
#19 0x0075ed9d in ucbhelper::cancelCommandExecution ()
#20 0x1868b9ed in component_writeInfo ()
#21 0x18678c00 in component_writeInfo ()
#22 0x1865c2ff in component_writeInfo ()
#23 0x1866391e in component_writeInfo ()
#24 0x00721364 in ucbhelper::Content::get ()
#25 0x0072314f in ucbhelper::Content::getPropertyValuesInterface ()
#26 0x00723493 in ucbhelper::Content::getPropertyValues ()
#27 0x007237dd in ucbhelper::Content::getPropertyValue ()
#28 0x00723a12 in ucbhelper::Content::isDocument ()
#29 0x00729848 in ucbhelper::Content::openWriteableStream ()
#30 0x0061f526 in comphelper::MediaDescriptor::PROP_UCBCONTENT ()
#31 0x006222f2 in comphelper::MediaDescriptor::addInputStream ()
#32 0x18753905 in SfxMedium::GetCharset ()
#33 0x18757042 in SfxMedium::GetStorage ()
#34 0x1875e1bb in SfxMedium::GetOutputStorage ()
#35 0x1878a768 in SfxObjectShell::SaveAs ()
#36 0x1878dbbc in SfxObjectShell::SaveAs ()
#37 0x1878e550 in SfxObjectShell::SaveAs ()
#38 0x1879546b in SfxObjectShell::GetDocumentSignatureState ()
#39 0x187e7c26 in SfxBaseModel::Notify ()
#40 0x187e8f0c in SfxBaseModel::storeAsURL ()
#41 0x187fa74d in SfxBaseModel::getUIConfigurationManager ()
#42 0x187967b2 in SfxObjectShell::GetDocumentSignatureState ()
#43 0x18851a2f in SfxDispatcher::Execute ()
#44 0x18852133 in SfxDispatcher::_Execute ()
#45 0x1887c981 in SvxSearchItem::QueryValue ()
#46 0x1887c931 in SvxSearchItem::QueryValue ()
#47 0x011c39a6 in Window::~Window ()
#48 0x01230bf8 in component_getFactory ()
#49 0x92de8537 in DispatchEventToHandlers ()
#50 0x92de7bdc in SendEventToEventTargetInternal ()
#51 0x92de7aa1 in SendEventToEventTargetWithOptions ()
#52 0x92def123 in ToolboxEventDispatcherHandler ()
#53 0x92de88ee in DispatchEventToHandlers ()
#54 0x92de7bdc in SendEventToEventTargetInternal ()
#55 0x92deefbc in SendEventToEventTarget ()
#56 0x01248727 in SalGetDesktopEnvironment ()
Comment 5 shaunmcdonald131 2007-09-13 15:33:22 UTC
With the X11 version, commenting out lines 43 and 44 in soffice in the MacOS directory, doesn't help.

For reference, the lines are:
SAL_ENABLE_FILE_LOCKING=1
export SAL_ENABLE_FILE_LOCKING

There was a few similar issues previously, where by doing this change was a workaround.

See issue 29284
issue 60804
issue 61865
issue 62229

For related issues.
Comment 6 eric.bachard 2007-11-11 08:06:09 UTC
*** Issue 83527 has been marked as a duplicate of this issue. ***
Comment 7 Graham Perrin 2007-11-11 08:22:16 UTC
Adding as a keyword: 

Finder
Comment 8 Graham Perrin 2007-11-11 10:33:05 UTC
Re Finder and
/System/Library/Filesystems/webdav.fs/
in Mac OS X 10.4 

I wonder whether a MacFUSE-based WebDAV file system will fare better. 

I have posted to 
http://groups.google.com/group/MacFusion-devel/browse_frm/thread/2089d41bae8fb1a8/

-- I'm a member of the MacFusion project.
Comment 9 Graham Perrin 2008-01-02 23:30:26 UTC
FWIW: what may be a comparable issue with NeoOffice was fixed in November 2007. 

You'll find a link to the NeoOffice ticket via 
http://www.nabble.com/WebDAV-%28PLIP--187%29-and-OpenOffice.org-td14558075s6745.html

Regards
Graham
Comment 10 eric.bachard 2008-02-03 12:16:58 UTC
Set target

Would be great to have this feature working for 3.0 
Comment 11 Graham Perrin 2008-02-03 19:35:37 UTC
> I wonder whether a MacFUSE-based WebDAV file system will fare better. 

Someone reported to me that results whilst using 
wdfs 
were no more promising than whilst using Apple-installed 
/System/Library/Filesystems/webdav.fs/

Right now I can't find that report but AFAIR it was fairly generic (not OOo-specific).
Comment 12 drenalin 2008-07-10 18:16:50 UTC
Reporting that this is still an issue on OS X 10.5.4, OOo 3.0.0 beta.  Tested
trying to open .xls, .doc files on both an iDisk mounted volume and also
JungleDisk volume (which uses Amazon's S3 service as a backend).

SMB (via samba) mounted volumes are working just fine in the same testing.
Comment 13 alex.thurgood 2008-07-16 11:53:27 UTC
Confirming and setting oooqa keyword.
Tested with 00o 2.4 X11
OOo Aqua 2.4
OOo Aqua 3.0 m19

All fail to load a file directly (i.e. by double-clicking on file) from a webdav
share that is mounted in the OS.

It is possible to open and write webdav shared files in OOo 2.4 X11 if you load
the file from within OOo by typing the HTTPS reference from the URL file
control. This control is not available in the Aqua versions, it appears to have
been done away when the native Mac OS open file dialogue code was integrated.

As a comparison, the functionality appears to work as intended for me in the
latest version of NeoOffice.


Alex
Comment 14 eric.bachard 2008-07-16 12:36:46 UTC
@wurzel 

Waiting this isssue to be fixed, I announced, some times ago, on the french lists and maybe mac@porting 
list too  (means you cannot ignore the mail), an howto use webdav with OpenOffice.org 3.x.

=>   http://eric.bachard.free.fr/mac/aquavcl/webdav/

Both fr and en-US versions are available

Comment 15 eric_openoffice 2008-07-16 13:21:39 UTC
maveric-->ericb:

I think what Alex wants is that we can use webdav with the the native finder
dialogue and not only with the OOo owns dialogues.

I think therefore we should close this issue because saving on webdav is
possible and open a new issue that deals with the native finder dialogue not
able to save to webdav folders.
Comment 16 alex.thurgood 2008-07-16 23:59:53 UTC
All I did was confirm this as a QA member, and indicate that it worked in X11
via the OOo dialogues, and that it also worked natively in NeoOffice. If the
problem is solved as Eric suggests in his How-to (which it would seem to be
because it re-establishes the OOo dialogues), then why wasn't the issue closed ?

I only stumbled across the issue because I was trying out webdav access from a
remote network to my work machine, found that it didn't work, searched in IZ and
came across it. I'm perfectly willing to accept the workaround until such time
as the native file picker implementation can be completed to work with webdav,
but in that case the issue should be marked Resolved WFM. If someone wants to
open an issue, as Maverick suggests, for incomplete native finder functionality
then that is fine by me.

Alex
Comment 17 ldubost 2008-07-28 20:58:38 UTC
The fact that it works with the OOo dialogues is not good enough. First because
they are not activated by default, second because they are not called when using
a mounted webdav drive and double clicking on a file. It is completely different
code that is called when using the OOo dialogues (it's internal OpenOffice web
dave calls instead of trying to interact with a webdav mounted folder using the
standard I/O apis).

I've a patch that makes webdav work by ignoring some return codes that MACOSX
returns when locking files and also changing the locking flags.

I've tested the patch with a webdav folder and with DEV300_m27

I'm attaching the patch after this comment. 
Comment 18 ldubost 2008-07-28 21:10:49 UTC
Created attachment 55413 [details]
Make webdav work on Mac OSX
Comment 19 ldubost 2008-07-28 21:11:35 UTC
For those who want to try the patch on an Mac OSX install, here is a built version:

http://www.ludovic.org/xwiki/bin/download/Main/OOPatch/libunosal.dylib.3

It replaces the one in
/Applications/OpenOffice.org.app/Contents/basis-link/ure-link/lib

It works as a replacement to the one in OO 3.0b2 (BEB300m3 build 9328)
Comment 20 eric.bachard 2008-07-28 21:14:32 UTC
@ldubost

Thank you very much for your patch. Looks very interesting.

One important thing is, we can only accept code from people who have accepted SCA. Do you ?
Comment 21 ldubost 2008-07-28 21:36:30 UTC
I haven't accepted the SCA but I'll be happy to do it if somebody tells me the
procedure
Comment 22 eric.bachard 2008-07-28 21:39:09 UTC
@ldubost

Your patch works fine, and this is a very valuable fix. Thanks a lot !

For the SCA, please have a look at : http://wiki.services.openoffice.org/wiki/JCA

Comment 23 ldubost 2008-07-30 13:38:30 UTC
I've sent a signed SCA. Looking forward to see OpenOffice 3 release working
natively on Mac :)
Comment 24 eric.bachard 2008-07-30 13:44:27 UTC
@pl : if there is no leagl issue, do you have an objection to commit the fix (yourself) into vcl92 or any 
open cws ? I tested the fix, and it looks ok to me 

(and I'm on holidays today ;-) )
Comment 25 philipp.lohmann 2008-07-30 18:35:31 UTC
pl->hro: the patch disables locking if the file system does not support it,
pretending success. This will probably work for opening but may lead to problems
afterwards since there is no real file lock. E.g. the calc collaboration depends
on file locking if I remember correctly ?

Please advise.
Comment 26 eric.bachard 2008-07-30 20:13:59 UTC
@pl : I completely missed that :-/   Thanks for your expertise. 

Since, I took some time to read more the code, and I think we could add an item on the Roadmap : 
upgrade the code in sal for Mac OS X.

Reading some comments in system.c, I think it really worth it: there is still code for 10.1 , 10.2 or 10.3 
and some old hacks (like macxp_getSystemVersion()  ) we should remove or at least upgrade. But I can be 
wrong again (sorry, I really believed it was ok with the patch).


Comment 27 ldubost 2008-07-30 20:24:12 UTC
If a feature relies on locking but locking is not available, I don't see how you
would make it work anyway.

The patch allows at least to open and save files if locking is not available (in
fact on Mac OSX WebDAV, locking IS available, but the OS says not implemented
although it might have worked).

In any case I don't really see how the patch harms the case when things are ok.
For me it just allows to pass fence 1 (cann't open and save files) in the case
it does not work. Althout it might not pass fence number 2 (where locking is needed)

Since the patch is all in #ifdef MAXOSX AND does not do anything if locking is
there, isn't it a non dangerous patch ?
Comment 28 kai.sommerfeld 2008-07-31 08:43:28 UTC
Sorry guys, but deadline for 3.0 code freeze has passed already. Today is last
CWS integration day. We're in a phase where only show stoppers are fixed and
integrated for 3.0. IMO, this issue is not a show stopper. If nobody minds, I
will retarget it to 3.1
Comment 29 hennes.rohling 2008-07-31 11:51:44 UTC
The patch looks good but we'll integrate it for 3.1 because it's not a show stopper.
Comment 30 ldubost 2008-08-01 10:43:10 UTC
Anyway I found that only Calc is able to open and save. Apparementy impress and
writer cannot save to the webdav directory. The SAVE button is greyed and Save
AS says "Error saving document. Object inaccessible. The object cannot be
accessed due to insufficient user rights". And I'm pretty sure this is not a
rights issue. Calc can save files in this area
Comment 31 ldubost 2008-08-05 18:45:58 UTC
Forget my previous comment. It works well with Writer and Impress. It was due to
missing implementation in the webdav server
Comment 32 Graham Perrin 2008-09-10 16:43:32 UTC
See also http://dev.plone.org/plone/ticket/8478 in which OOo 3.0.0rc1 on Mac OS X 10.5.4, Intel, stops 
responding (fails to present an error dialogue) and must be forced to quit.
Comment 33 Graham Perrin 2008-09-10 17:11:45 UTC
Even after I force quit OpenOffice.org, and after I follow the prompt to report the problem to Apple, I find 
that OpenOffice.org remains in the list of _running_ applications in the 'Force Quit Applications' window. 

Only after I forcibly unmount the volume(s) in question --

[macbookpro03:~] gjp22% sudo umount -f /Volumes/profitnetbook/
[macbookpro03:~] gjp22% sudo umount -f /Volumes/dav

-- will applications that are not responding (and in that state relative to a WebDAV volume) disappear 
from the list of running applications. 
Comment 34 Graham Perrin 2008-09-10 17:14:39 UTC
Created attachment 56390 [details]
an earlier Apple-oriented report following a forced quit of OOo 3.0.0rc1
Comment 35 Graham Perrin 2008-09-10 17:14:48 UTC
Created attachment 56391 [details]
a more recent Apple-oriented report following a forced quit of OOo 3.0.0rc1
Comment 36 Graham Perrin 2008-09-10 17:15:58 UTC
Created attachment 56392 [details]
OpenOffice.org remained amongst the list of running _and responding_ applications _after_ a quit had been forced due to non-responsiveness
Comment 37 Graham Perrin 2008-09-10 17:17:13 UTC
Created attachment 56393 [details]
TextWranger also stopped responding after trying to save to the same WebDAV volume with which OOo was having difficulty
Comment 38 Graham Perrin 2008-09-10 17:17:23 UTC
Created attachment 56394 [details]
a through-the-Plone view of some OOo-related debris at the root of the WebDAV volume, where the saves were attempted
Comment 39 Graham Perrin 2008-10-11 13:19:35 UTC
> Even after I force quit OpenOffice.org, and after I follow the
> prompt to report the problem to Apple, I find that
> OpenOffice.org remains in the list of _running_ applications in
> the 'Force Quit Applications' window.

That may be a different issue 62312.
Comment 40 hennes.rohling 2008-10-15 13:40:02 UTC
@grahamperrin: This has absolutely nothing to do with the issue you mentioned. I
don't want to explain further but  #62313 is something very specific to Windows
only.
Comment 41 Graham Perrin 2008-10-21 16:46:49 UTC
apologies to all for the confusion - Graham
Comment 42 eric.bachard 2008-12-14 08:12:25 UTC
What happens with this issue ? 

Will we wait to misee the 3.1 deadline before to do something ?

Comment 43 eric.bachard 2008-12-14 08:13:15 UTC
s/misee/miss/
Comment 44 hennes.rohling 2009-01-26 12:15:52 UTC
Fixed on CWS macwebdav
Comment 45 hennes.rohling 2009-01-26 12:44:29 UTC
Reassigned for verification
Comment 46 joerg.skottke 2009-01-28 13:32:38 UTC
Verified together with TM
Comment 47 thorsten.martens 2009-05-04 09:27:11 UTC
closed