Issue 81636 - the text from different cells is overlapped
Summary: the text from different cells is overlapped
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 2.4.1
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: OOo 3.x
Assignee: thomas.lange
QA Contact: issues@gsl
URL:
Keywords: oooqa
Depends on: 96397 88864 94387 107600
Blocks:
  Show dependency tree
 
Reported: 2007-09-17 09:52 UTC by denis_kostousov
Modified: 2010-06-24 17:09 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
print preview with overlapping (114.97 KB, image/png)
2007-09-17 09:54 UTC, denis_kostousov
no flags Details
example document (14.92 KB, application/vnd.oasis.opendocument.spreadsheet)
2007-09-17 09:55 UTC, denis_kostousov
no flags Details
needless space between text lines (166.70 KB, image/png)
2007-10-17 09:46 UTC, denis_kostousov
no flags Details
needless space between text lines (85.40 KB, image/png)
2007-10-17 09:52 UTC, denis_kostousov
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description denis_kostousov 2007-09-17 09:52:59 UTC
I created some document (my work report before weekend) using OOCalc. The cells
of third column have a long russian text. After creating I pressed button "print
preview" and saw overlapped text on page. 
Then the cell's font was changed for all cells (I selected all document by
pressing Ctrl-A and changed font via toolbar) several times. There was no the
problem with some fonts (Times New Roman Cyr, 10; Arial, 10;).
The problem was  repeated when the document was exported to pdf.
The «Liberation Serif, 10» font was used for the document.

OS: Fedora Linux 7
OOffice: 2.3.0 from Fedora development repository
(openoffice.org-calc-2.3.0-4.1.fc7)
freetype-2.3.4-3.fc7
Comment 1 denis_kostousov 2007-09-17 09:54:24 UTC
Created attachment 48269 [details]
print preview with overlapping
Comment 2 denis_kostousov 2007-09-17 09:55:16 UTC
Created attachment 48271 [details]
example document
Comment 3 philipp.lohmann 2007-09-17 09:56:54 UTC
pl->hdu: could you please have a look
Comment 4 hdu@apache.org 2007-10-16 10:40:52 UTC
The bugdoc triggers plenty of assertion messages ("Alternate: Falsche Annahme! From File SRC680/
src.m232/svx/source/editeng/impedit3.cxx at line 1887) in ImpEditEngine::ImpBreakLine() which is most 
probably the root cause of the problem.

I haven't been able to reproduce the exact problem though, but there is something quite messed up in the 
line layout.
Comment 5 thomas.lange 2007-10-16 11:04:47 UTC
tl->denis_kostousov: for better comparison can you please provide the Writer
document that matches the screen shot? Thanks in advance!
Comment 6 denis_kostousov 2007-10-17 08:52:46 UTC
I tried to repeat the problem with the file was attached to the bug. The problem
didn't repeat. But I change the freetype library to non-free version after
posting the bug. The problem repeated with the file after the freetype library
was changed to defaut version from Fedora 7 Updates.

denis_kostousov -> tl: What do you want? Should I create the same document with
OOWriter?
Comment 7 denis_kostousov 2007-10-17 09:45:30 UTC
I have installed the freetype library from Tigro repository
(http://mirror.yandex.ru/fedora/tigro). The problem has changed. There is no
more of text overlapping, but now there is some needless space between text lines.
See new attachments.
Comment 8 denis_kostousov 2007-10-17 09:46:57 UTC
Created attachment 48961 [details]
needless space between text lines
Comment 9 denis_kostousov 2007-10-17 09:52:42 UTC
Created attachment 48962 [details]
needless space between text lines
Comment 10 frank.meies 2007-10-17 10:40:44 UTC
Removed cc.
Comment 11 frank 2007-11-07 14:15:27 UTC
targeted
Comment 12 stefan.baltzer 2008-10-29 14:17:33 UTC
SBA: This issue has a target set but is still in state of "Unconfirmed".
Please re-check with OOo 3.0 or younger if it is (still) valid.
Then confirm it or set an appropriate resolution.
Thank you.
Comment 13 stefan.baltzer 2008-10-29 14:24:40 UTC
SBA: This issue has a target set but is still in state of "Unconfirmed".
Please re-check with OOo 3.0 or younger if it is (still) valid.
Then confirm it or set an appropriate resolution.
Thank you.
Comment 14 denis_kostousov 2008-10-29 18:39:45 UTC
How is it to confirm a bug?

I checked version 2.4.1 from Fedora 9. The bug is still there.
Comment 15 Mechtilde 2010-01-23 20:18:36 UTC
There are many different issues with different description touching the same
technical reason.

this is not easy to reproduce in all situations

but

It depends on which font and type face you use.

sometimes if you print the document or use the pdf export not the same type face
is used.
Comment 16 Mechtilde 2010-01-23 20:29:24 UTC
similar to especially 107600
Comment 17 Mechtilde 2010-06-11 19:56:31 UTC
please check it with DEV300_m81 or newer
Comment 18 Mechtilde 2010-06-24 16:50:55 UTC
I set it to worksforme with version DEVm80 and later

If you find a similar problem please open a new issues with an exact description
how to reproduce the problem.
Comment 19 Mechtilde 2010-06-24 17:09:30 UTC
worksforme -> closed