Issue 81705 - Cannot print database report created with the wizard
Summary: Cannot print database report created with the wizard
Status: CLOSED DUPLICATE of issue 82625
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.3
Hardware: Other Windows 2000
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.3.1
Assignee: Mathias_Bauer
QA Contact: issues@dba
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2007-09-18 15:33 UTC by buschu
Modified: 2007-12-10 20:41 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document to reproduce the bug case (10.65 KB, application/vnd.sun.xml.base)
2007-09-19 10:08 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description buschu 2007-09-18 15:33:31 UTC
I created a report in base with the wizard. Then I opened the report (it shows
me, that the writer is used to visualize the report).
If I try to print the report, the printer dialog appears, but printing does not
work. I can print normal writer documents from writer, but not a report.
Comment 1 Regina Henschel 2007-09-18 16:00:23 UTC
Which database do you use?

Can you print using OOo2.2.1?

Is this a new report or have you created it with an earlier version?
Comment 2 rfjguzzo 2007-09-18 20:30:30 UTC
I have the same problem, was created in 2.2.1 and printed using file/print and 
direct print from toolbar, no problem.

Stopped printing after intalling 2.3 RC1, I have removed completely and 
reinstalled, but still not printing reports.  As a work around, I use the PDF 
option to create PDF and then print the PDF.

Running XP Pro, with all updateds from MS installed.
Comment 3 Regina Henschel 2007-09-18 21:06:11 UTC
changed summery to make clear that it not an issue with the new Report Builder.

From PagePreview all kind of printing works: PrintPagePreview, File>Print,
PrintDefault

From normal view neither PrintDefault nor File > Print works.

Here on Win XP Home, German OOo2.3rc3.
Comment 4 buschu 2007-09-19 08:18:07 UTC
I use DB2. To install OOo2.2.1 again I must get the setup file from home. It's a
new report created with V2.3. I can confirm that printing from the page view works.
Comment 5 Frank Schönheit 2007-09-19 10:07:43 UTC
confirming, targeting, assigning
Comment 6 Frank Schönheit 2007-09-19 10:08:26 UTC
Created attachment 48323 [details]
document to reproduce the bug case
Comment 7 Frank Schönheit 2007-09-19 10:10:36 UTC
the attached document allows to reproduce the problem. Simply open it,
double-click the contained report to execute it, and press Ctrl-P in the
resulting text document. After confirming the "Print" dialog, nothing happens.
Comment 8 marc.neumann 2007-09-19 11:53:28 UTC
change summary
Comment 9 Mechtilde 2007-09-26 11:08:27 UTC
add as CC
Comment 10 Oliver Specht 2007-09-28 14:01:58 UTC
->mba: It doesn't print because the Writer doesn't print documents without a
jobname. This is empty because SfxObjectShell::GetTitle(0) returns an empty
string. This happens because of the changes in rev. 1.92 of
sfx2/source/doc/objmisc.cxx
The question is which of the three parts are wrong:
- should GetTitle(0) return a string
- should the document have a title
- should the Writer print it also if it hasn't got a title (that might be true
either way)
Comment 11 Mathias_Bauer 2007-09-28 14:28:16 UTC
GetTitle(0) always was fuzyy; according to the in-source documentation it should
return the title "as is". Unfortunately the internal member pImp->aTitle is not
very well defined. To me this is not reliable.

The question remains why Writer refuses to print documents without a title.
Perhaps this should be clarified first.
Comment 12 staho 2007-10-03 07:05:50 UTC
The same problem appears when printing a Base form: works only via Print Preview
(which works only in "view|Print layout", while "Web layout" is the default).

Cannot print neither when editing nor executing report/form.

BTW: Is there a workaround?
Comment 13 Oliver Specht 2007-10-04 07:27:01 UTC
->staho: The workaround is to "save as" the document and then to print it.

The reason for the title requirement is that the title is used as job name of
the print job which in turn is necessary to see a document name in the print
queue of the operating system.
Comment 14 ogfomk 2007-10-06 19:17:20 UTC
I had the same problem.  I run XP and I run Linux Ubuntu.  I have been able to
use an older version of OO from a portable app on my usb drive to open an OObase
and run my report and print it.  

My work around was to export as PDF and then print or to save a OOwriter and
then open and print.  Maybe I can make a macro to do this.  I would love it if
this issue was fixed.
Comment 15 Oliver Specht 2007-10-23 14:26:14 UTC
Using GetTitle(SFX_TITLE_APINAME) works.

*** This issue has been marked as a duplicate of 82625 ***
Comment 16 Mechtilde 2007-12-10 20:41:43 UTC
closed the duplicate