Issue 81784 - In calc HIDE rows does not work correctly in MACRO
Summary: In calc HIDE rows does not work correctly in MACRO
Status: CLOSED DUPLICATE of issue 38013
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 2.2.1
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-09-20 16:36 UTC by rk601
Modified: 2008-01-23 20:54 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rk601 2007-09-20 16:36:16 UTC
Description of Problem:

[calc MACRO problem]

The problem occurs on a Windows XP computer running OOo 2.2.1. When recording a
MACRO within calc and hide rows is used then the data within the rows
disappears, but the rows are not hidden.

Steps to reproduce the problem:
1. Begin MACRO recording, and select rows say 1 to 3.
2. Apply Format, Column, Hide.
3. Stop recording, and save MACRO.
4. Obtain a fresh (new) data set without borders or formating.
5. Run the MACRO.
6. The data within the rows disappears, but the rows are not hidden.

Actual Results:

The data within the rows disappears, but the rows are not hidden.

Expected Results:

The MACRO should always hide the desired rows as recorded by the MACRO.

How often does this happen?

This error always occurs.


Additional Information (OS patch level, drivers, library
version, etc.)
Comment 1 Rainer Bielefeld 2007-09-20 19:34:02 UTC
For me not reproducible with "2.3.0 RC3  Multilingual German version WIN XP:
[680m5(Build9221)]" and "2.0.2  German version WIN XP: [680m5(Build9011)]" 
Comment 2 kpalagin 2008-01-23 20:41:20 UTC
Seems to be dup to http://www.openoffice.org/issues/show_bug.cgi?id=38013.

*** This issue has been marked as a duplicate of 38013 ***
Comment 3 kpalagin 2008-01-23 20:54:58 UTC
Closing.