Issue 82435 - Images inserted with drag'n drop are not embedded by default
Summary: Images inserted with drag'n drop are not embedded by default
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: configuration (show other issues)
Version: OOo 2.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords: usability
: 104835 110569 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-10-09 13:29 UTC by bblankenburg
Modified: 2017-05-20 10:24 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bblankenburg 2007-10-09 13:29:51 UTC
I made a presentation containing several images, which I inserted by drag'n drop
from my desktop. When I copied the presentation file over to the presentation
laptop, the images did not show because they were not embedded but only linked.
So in this case the presentation was broken in favour of "wasting" space. So in
effect efficiency is considered more important than correctness, which I believe
is the wrong way.
Comment 1 wolframgarten 2007-10-09 15:53:29 UTC
Dragging graphics in with the CTRL button pressed shows a little "+"-sign, which
should insert a copy and not a link. But they are linked.
Comment 2 Martin Hollmichel 2007-11-09 17:18:55 UTC
set target from 2.x to 3.x according to
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 3 frank.loehmann 2009-10-15 13:26:55 UTC
set usability keyword.
Comment 4 frank.loehmann 2009-10-15 13:33:56 UTC
*** Issue 104835 has been marked as a duplicate of this issue. ***
Comment 5 weko 2009-10-16 09:37:41 UTC
I checked this matter:

- Writer, Calc, Draw and Impress: If I insert an image via the menu "Insert|Picture|From File..." the 
default is *embedded*.

- Writer and Calc - Drag&Drop: Default is *embedded*.

- Draw and Impress - Drag&Drop: Default is *linked*.

IMO the default must be *embedded*. There are two reasons:

1. Consistency
2. The "normal" user expects, that images are embedded (scenario see above (bblankenburg)).

P.S.: Set target to 3.3 as disdussed with FL.
Comment 6 clippka 2009-11-16 14:29:41 UTC
fixed in cws impress181 for OOo 3.3
Comment 7 clippka 2010-01-08 13:51:54 UTC
verified in cws, back to qa
Comment 8 wolframgarten 2010-01-13 13:32:00 UTC
Verified in CWS.
Comment 9 Regina Henschel 2010-04-03 12:49:49 UTC
*** Issue 110569 has been marked as a duplicate of this issue. ***