Issue 82465 - Wrong languge propose when spell checks
Summary: Wrong languge propose when spell checks
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@lingucomponent
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-10 12:30 UTC by h.hristov
Modified: 2013-02-24 20:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot of the problem (14.46 KB, image/png)
2007-10-10 12:31 UTC, h.hristov
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description h.hristov 2007-10-10 12:30:48 UTC
Using Ooo 2.3
Installed Bulgarian dictionaries.
In Writer I wrote some text in Bulgarian an make some wrong words.
When I pop up context menu on wrong word at the end I have: "The word is in
Russian" and "The paragraph is in Russian". Some time instead Russian it
is Ukrainian.
Comment 1 h.hristov 2007-10-10 12:31:50 UTC
Created attachment 48805 [details]
screenshot of the problem
Comment 2 h.hristov 2007-10-11 14:08:49 UTC
Checked and wiki page edited.
Comment 3 h.hristov 2007-10-11 14:10:47 UTC
Sorry, I wrote in wrong issue.
Comment 4 stefan.baltzer 2008-02-04 18:23:23 UTC
SBA: For OOo 2.4, there is a new feature to help setting languages. Now the
context menu for a wrong word has more languages to choose from, always
including the ones that are set to the document and not only the "guessed" one
as in OOo 2.3.

Please re-verify your findings in OOo 2.4 (currently, OOH_m4 dev builds are
available) and comment here. Thank you.

Reassigned to me.


Comment 5 thomas.lange 2008-02-05 10:24:10 UTC
Well that is probably to be expected since Russian, Ukrainian and Bulgarian all
use the Cyrillic character set.
It seems the languages are similar are enough to confuse language guessing. The
chance is though that if the sentence gets longer has more language specific
characteristics in it the correct language will be found...

Similar problems are to be expected with e.g. English-US and English-GB or
Germany-Germany and German-Swiss.

Still, if you at least already have once used Bulgarian as text attribute in the
document (and do not use too many other languages as well) from then on
Bulgarian should also appear in the list of languages, since the first few
document languages are added to the language list in the menu as well.
Comment 6 thomas.lange 2008-02-05 10:25:13 UTC
.
Comment 7 h.hristov 2008-02-14 14:10:19 UTC
Now is better. 10x :)
Comment 8 thomas.lange 2008-02-15 09:00:43 UTC
Well, that is nice to hear! ^__^
Comment 9 stefan.baltzer 2008-03-05 09:56:04 UTC
SBA: I take the comment of icobgr as a "worksforme". Set resolution accordingly.
Comment 10 stefan.baltzer 2008-03-05 11:23:10 UTC
Closed.