Issue 82494 - cannot paste any text into Basic IDE
Summary: cannot paste any text into Basic IDE
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 680m231
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: OOo 2.4
Assignee: joerg.skottke
QA Contact: issues@framework
URL:
Keywords: regression
: 83189 83272 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-10-11 08:44 UTC by Frank Schönheit
Modified: 2008-10-26 15:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2007-10-11 08:44:44 UTC
- open the Basic IDE with an arbitrary basic script of your choice
- mark any text, copy it to the clipboard.
- paste the text from the clipboard (Edit/Paste, or Ctrl+V)
=> error message:
   "The inserted text exceeded the maximum length of this text field. The text was
   truncated."
=> nothing is actually inserted

This even happens when you try to paste a single character
Comment 1 Frank Schönheit 2007-10-11 08:48:28 UTC
fs->ab: As we saw, this does not happen in m227 => regression

Also, you might be right with assuming that this is a base class problem:
Basically, TextView::Paste is called upon a paste attempt. This calls
TextView::ImplTruncateNewText (svtools/source/edit/textview.cxx), which asks its
text engine for the maximum text length. This max text length is claimed to be 0
- thus, the complete text is truncated.
Comment 2 ab 2007-10-16 12:03:53 UTC
ab->pl: This problem obviously came in with cws vcl82 where you added
TextView::ImplTruncateNewText() in source/edit/textview.cxx. It seems to 
me that a MaxTextLen of 0 in this context means unlimited  (e.g. look at 
TextView::ImplCheckTextLen) but in ImplTruncateNewText() this isn't
considered.
Comment 3 philipp.lohmann 2007-10-17 14:15:48 UTC
oops, fixed in  CWS vcl83
Comment 4 cno 2007-10-18 08:38:01 UTC
Is the same as issue #82438
I'll close that one
Comment 5 philipp.lohmann 2007-10-23 12:45:11 UTC
please verify in CWS vcl83
Comment 6 ab 2007-11-01 10:15:54 UTC
*** Issue 83189 has been marked as a duplicate of this issue. ***
Comment 7 sgautier.ooo 2007-11-06 15:22:16 UTC
*** Issue 83272 has been marked as a duplicate of this issue. ***
Comment 8 joerg.skottke 2007-11-21 13:50:21 UTC
Verified using Linux, ctrl+v, shift+ins, menu, Sun Keys.
Comment 9 jbf.faure 2008-02-02 22:08:43 UTC
Is there any reason to not close this issue ?
Comment 10 cno 2008-02-05 13:49:26 UTC
Not afaik -> CLOSED
Comment 11 rupike 2008-03-31 07:50:03 UTC
I installed the new version of the OpenOffice 2.4 and did next steps:

- open the Basic IDE with an arbitrary basic script of your choice
- mark any text, copy it to the clipboard.
- paste the text from the clipboard (Edit/Paste, or Ctrl+V)
=> error message:
   "The inserted text exceeded the maximum length of this text field. The text 
was
   truncated."
=> nothing is actually inserted
Comment 12 rschiwal 2008-05-12 06:39:01 UTC
This problem isn't fixed.  Just installed version 2.4.0 and my project has come 
to a screeching halt because of this very problem.  Would like to know how to 
fix this closed problem.
Comment 13 rschiwal 2008-05-12 08:12:54 UTC
One more note,  It seems my script is too long.  Paste works on empty script 
but not on long .bas script.
Comment 14 Frank Schönheit 2008-05-12 13:18:42 UTC
I wouldn't be surprised if the Basic IDE had a limit of 64K, or something like
this, for pasting. Perhaps your "long" script exceeds such a limit.

This very bug here described the problem that you cannot paste *any* text into
the IDE, not even a single character.
Comment 15 rschiwal 2008-05-12 17:22:58 UTC
This is just that, once the script hits about 1600 lines I can't paste a single 
character from the clipboard.  I am still able to jump to another module and 
paste and I can still replace text in the first.  One other peculiarity I 
noticed, and it may or may not be part of this problem (One post, one problem), 
When I try to copy and paste I usually right click my mouse for the little pop-
up menu.  This is also absent.  I only mention this because I think it may be 
related to our current problem.
Comment 16 Frank Schönheit 2008-05-12 19:54:32 UTC
I indeed think it isn't related. The problem that the module size is limited was
also present before this bug here - which means you cannot paste even the
smallest text from the clipboard to the smallest module -, so I think it's
unrelated.
Comment 17 djarthurs 2008-10-26 15:56:27 UTC
This is still there in 300m9 3.0 release
Duplicated in issue 87601