Issue 82509 - Can't insert multiple rows in a table
Summary: Can't insert multiple rows in a table
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.3
Hardware: PC Windows XP
: P4 Trivial with 5 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: regression
: 95005 (view as issue list)
Depends on:
Reported: 2007-10-11 12:54 UTC by jazzynico
Modified: 2013-08-07 14:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Rows insertion action (10.19 KB, text/plain)
2007-10-11 12:58 UTC, jazzynico
no flags Details
Rows insertion result (5.91 KB, text/plain)
2007-10-11 12:59 UTC, jazzynico
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jazzynico 2007-10-11 12:54:20 UTC
When you select 2 (or more) rows in a table and right-click to row->insert, only
the last selected row is inserted.
Worked well in previous versions.
swnewtable bug?
Comment 1 jazzynico 2007-10-11 12:58:30 UTC
Created attachment 48838 [details]
Rows insertion action
Comment 2 jazzynico 2007-10-11 12:59:04 UTC
Created attachment 48839 [details]
Rows insertion result
Comment 3 michael.ruess 2007-10-11 13:26:30 UTC
MRU->AMA: maybe really a regression of swnewtable...
Insert a table, select two or more rows and click "Insert row" button -> only
one row will be inserted.
Comment 4 jazzynico 2007-10-11 13:46:43 UTC
An ugly workaround:
Copy the selected rows and paste it as a new table.
Then merge the two tables.
Comment 5 andreas.martens 2007-10-11 14:50:45 UTC
Yes, I changed this behavior with swnewtable. But I would not call this a
regression, for me it is a progression :-)
What do you want?
Do you want to insert more than one row? You should use table/insert/row and you
will get the number of rows you wanted.
Or do you want to split rows? Then you should select the rows you want to split
and use table/cells/split.
Comment 6 jazzynico 2007-10-11 15:17:56 UTC
I just want to insert a group of rows, duplicate of the selected rows. Exemple:

I select two rows:
Row 1: cell 1  | cell 2
Row 2: ---- cell 3 ----

With 2.2, I get what I need (by doing Row->Insert->1,after):

Row 1: cell 1  | cell 2
Row 2: ---- cell 3 ----
Row 3: cell 1  | cell 2
Row 4: ---- cell 3 ----

With 2.3, I get:
Row 1: cell 1  | cell 2
Row 2: ---- cell 3 ----
Row 3: ---- cell 3 ----

With split, I get:
Row 1: cell 1  | cell 2
Row 2: cell 1  | cell 2
Row 3: ---- cell 3 ----
Row 4: ---- cell 3 ----
Comment 7 andreas.martens 2007-10-11 17:15:12 UTC
Mmmh, I see.
I am interpreting your selection only as target for the insertion of rows, but
you want to copy these rows. I have to think about this, ATM I could imagine to
create a new 'table/copy/row' or 'table/duplicate/row'.
Comment 8 andreas.martens 2007-11-22 10:01:54 UTC
Set target to OOo3.0.
Improvement of table insertion is related ot issue 83791 as well
Comment 9 andreas.martens 2008-04-28 13:02:04 UTC
Set target OOo3.x
Comment 10 michael.ruess 2008-10-16 15:03:54 UTC
*** Issue 95005 has been marked as a duplicate of this issue. ***
Comment 11 grumpftl 2008-10-16 15:18:36 UTC
Sorry for the duplicate. This worked well even with 2.4.1.
As stated from jazzynico Thu Oct 11 14:17:56: You just copy the row-formating,
not the content. See behaviour in former OO.
For me, no extra button required: Button with selected rows inserts these # of
rows with their formating, Button without selection simply adds one row. And
adding >1 row without formating can be done with the pop-up.