Issue 82519 - Paste should replace selection
Summary: Paste should replace selection
Status: CLOSED DUPLICATE of issue 24500
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 2.3
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-11 16:09 UTC by nmailhot
Modified: 2008-02-02 10:33 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description nmailhot 2007-10-11 16:09:52 UTC
In all the desktop apps I use, when you select some content then paste the paste
content replaces the selection

When you do the same in writer the paste content is appended to the selection.

Please make writer behave the way users expect (like the other apps)
Comment 1 ralphie 2007-10-11 18:22:50 UTC
Can you describe that behaviour a bit more in detail? I tried, but could not
reproduce this:

In Writer, type "blah", select "blah", Edit->Copy, Edit->Paste, there is
still only one word "blah" on the screen, i.e. the selection is replaced. Do you
mean something completely different?
Comment 2 nmailhot 2007-10-11 18:39:50 UTC
1. go in an app, select A stuff (formated text, whatever)
2. copy it with ctrl+C
3. open an openoffice document, select B stuff
4. paste with ctrl+V

B is not systematically replaced with A in OO.o (usually when B is a whole cell
and A is complex formatted stuff in apps like Word or Notes)
Comment 3 ralphie 2007-10-11 19:13:58 UTC
Sorry, nmailhot, I still cannot reproduce this. For me the selection is replaced,
even if I copy from another program, I just tested. What do you mean by "whole
cell", as this is a Writer Issue? Also what platform (Operation System) are you
on, as you mention Word, so this is Windows XP? I am on Linux/Gnome, and the
selection (at least for text) is replaced for me each and every time.
Comment 4 nmailhot 2007-10-11 19:20:19 UTC
You have tables with cells in writer too.

I've just tested my home linux config, instead of appending like under windows
2000 it duplicated the pasted content in two cells. But I don't have the kind of
rich text cut source I have at work with windows
Comment 5 michael.ruess 2007-10-12 07:51:57 UTC
Reassigned to ES.
Comment 6 kpalagin 2008-01-22 04:59:48 UTC
nmailhot,
please provide sample file.
Comment 7 nmailhot 2008-01-31 17:51:16 UTC
@kpalagin

I don't see how a sample file would help, the problem happens when you
manipulate tables, and both the version before and after the document have no
problem (except text was pasted at the wrong place)

I'll mark this as a dupe of issue 24500 since it's but one of the numerous
annoying and time-consuming quirks of OO.o when you try to paste from or into tables
Comment 8 eric.savary 2008-02-01 23:07:35 UTC
@nmailhot: as you said duplicate of issue 24500, I close as well.

But please next time, try to express yourself a little bit more precisly...
Avoid the "stuff" and "go in an app"... make a step by step description, name
the things by their names and explain what you do.

You will then spare our working time.

Thanx!

*** This issue has been marked as a duplicate of 24500 ***
Comment 9 eric.savary 2008-02-01 23:07:47 UTC
closed
Comment 10 nmailhot 2008-02-02 10:33:20 UTC
@es please realize your users are not all native english speakers, they do not
all use an English localization with English terms on the ui, and their living
is not writing office suites so they don't use office suite jargon every week.
Also that OO.o has lots of bugs that happen once in a while without any clear
reason for the end user they happen this time and not the next.

If you feel I didn't make enough efforts to get through in that bug I can
reverse the compliment. I chose to consider it a dupe of issue 24500 even if
it's not a perfect one to avoid writing a nastigram, so complaining about wasted
time is a bit rich now. I wasted my time too trying to figure how to transform a
complex bug in the simple explanation you wanted, and I was not even paid to do so.