Issue 82577 - ODBC is not working anymore 2.3.M5 +m232
Summary: ODBC is not working anymore 2.3.M5 +m232
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.3
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: dbaneedsconfirm
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-13 00:37 UTC by mhatheoo
Modified: 2007-10-28 21:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mhatheoo 2007-10-13 00:37:02 UTC
it looks the same as in issue 82076 and issue 81661:

Try to use an established ODBC-connection from the ODB-Navigator-Window will
crash OOO (this on 2.3RC3 (m5) aswell as on M232 - ooo stalls at 99% CPU

Using the same connection from within the writer (exchange database) seems to
work fine
Using propriatary driver from OOO seems to work (that ODBC is essential and they
can not be used for other reasons is another story)

Martin
Comment 1 Frank Schönheit 2007-10-13 20:53:33 UTC
What do you mean with "establish an ODBC connection from the ODB Navigator Window"?

What database type do you connect to? What database version / driver version do
you use?

What is the "proprietary driver from OOo"?
Comment 2 mhatheoo 2007-10-14 20:59:30 UTC
hello Frank

This is all windows:
- have a system-dsn with linking to a shared directory with dbIV-file via ODBC
- open ooo - database
- try new and to connect to that database via OOO-Odbc:
crash

Why do you ask for the version? Thats not important in here

as far I can see propratary are the buildin dbms-drivers
regarding DBaseIV I am not sure whether it had worked for 8-bit-decoding, but I
trust ODBC more (you remember that problem)

did I explained it well enough?

Martin
Comment 3 Frank Schönheit 2007-10-14 21:47:21 UTC
OOo does not ship ODBC drivers for dBase, so if you're in fact using ODBC, then
the driver versions might (or might not) make a difference. I'm always asking
that when an issue is that underspecified :)
Comment 4 Frank Schönheit 2007-10-15 10:16:38 UTC
cannot reproduce with "Microsoft dBase driver (*.dbf)" 4.00.6305.00, on Windows
XP service pack 2, in OpenOffice.org 2.3. Hmm.
Comment 5 Frank Schönheit 2007-10-15 10:17:05 UTC
Did you send a crash report, and received a report ID?
Comment 6 mhatheoo 2007-10-15 22:21:53 UTC
Hello Frank

step back: It seems to be related to driver-versions

it was: MDAC 2.8.0 + Jet4-SP8
As far as I know, the system-driver for DBAse-access is coming with the
JET-Engine, which is in here from the W2K-SP4-Rollout 1 - that
substitutes/overrules the Jet-Engine SP8 - Driverversions: 4.00.6200

The last version for access to the dbf-files through OBDC an was managed by the
OBDC-Drivers from MDAC 2.8.0. That did not work
I updated to the MDAC 2.8.0 SP1 dated 5/2005 (ProductBuild=2.81.1117.6) and now
the ODBC-driver is of version 3.525.1117 - now is works.

Frist tries gave weak performance - very slow - , but it worked, I have the
right code-page wroking and I can manage to create query to multiple (dbase)-files. 

so, thanks from here.
Maybe you need to circulate the infos for the need of this update

rgds
Martin
Comment 7 Frank Schönheit 2007-10-18 08:29:58 UTC
thanks for reporting back those details.

Can we close this issue then?
Comment 8 mhatheoo 2007-10-28 17:03:28 UTC
yes and no

as the compilation of ooo for windows2000 supports/requires a non-standard setup
only you need to mark that down somewhere.

However, it is up to you to close that issue, but doing so someone else might to
re-check my findings


Martin
Comment 9 Frank Schönheit 2007-10-28 21:24:21 UTC
closing
Comment 10 Frank Schönheit 2007-10-28 21:25:02 UTC
closing