Issue 82743 - report in bug doc misses the column named "Title"
Summary: report in bug doc misses the column named "Title"
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.3
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords:
: 89340 90491 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-10-18 08:01 UTC by Frank Schönheit
Modified: 2009-04-01 05:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document to reproduce the bug case (10.24 KB, application/vnd.sun.xml.base)
2007-10-18 08:03 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2007-10-18 08:01:46 UTC
- open the attached database document
- execute the contained report (which simply contains the two fields
  "Title" and "Status" of the database's only table) by double-clicking it
=> the content of the table field "Status" is displayed in the report column
   "Title", and the report column "Status" contains placeholder text only
Comment 1 Frank Schönheit 2007-10-18 08:03:21 UTC
Created attachment 48992 [details]
document to reproduce the bug case
Comment 2 Frank Schönheit 2007-10-18 08:05:21 UTC
renaming the "Title" column to something else (and re-creating the report to use
the new column) fixes the problem, so it seems we have a problem with the word
"Title" here.
Comment 3 berend.cornelius 2007-12-31 14:13:22 UTC
bc->fs: Please decide how important this problem is and set the target
appropriately.

*** This issue has been marked as a duplicate of 47269 ***
Comment 4 berend.cornelius 2008-01-21 10:02:40 UTC
bc: changing target to OOo 3.0 because of lack of resources to take care of this
problem.
Comment 5 drewjensen.inbox 2008-06-09 05:06:13 UTC
re-opening this issue as it is not a duplicate of 48992, which deals with the
title of the report, not a column named title.
Comment 6 drewjensen.inbox 2008-06-09 05:07:12 UTC
*** Issue 89340 has been marked as a duplicate of this issue. ***
Comment 7 drewjensen.inbox 2008-06-09 05:07:54 UTC
*** Issue 90491 has been marked as a duplicate of this issue. ***
Comment 8 drewjensen.inbox 2008-06-09 05:11:54 UTC
assigning to correct developer

ALso - issue 90491 shows that this error occurs only in Dynamic reports, static
reports to not exhibit the problem. I confirmed this under 2.4.1 RC2 and 3.0Dev
m_16 w/ XP.
Comment 9 lars.langhans 2008-06-13 06:34:51 UTC
Target changed to 3.x
Comment 10 lars.langhans 2008-07-01 10:37:17 UTC
If the DB contains a name like 'Title' it will renamed in something else like
Title_renamed_X where X is a number.
Comment 11 lars.langhans 2008-07-01 10:46:50 UTC
fixed
Comment 12 Frank Schönheit 2008-07-02 13:57:30 UTC
moved fix to CWS dba31a
Comment 13 lars.langhans 2008-07-18 08:30:56 UTC
reassigned
Comment 14 christoph.lukasiak 2008-08-06 15:04:34 UTC
verified in cws
Comment 15 vladimir_hitekschool 2009-04-01 01:46:09 UTC
Issue 82743 has been fixed in master version OOo-dev 3.1 .0 (OOO310m7 
Build:9393) for Windows XP and can be closed.
Comment 16 oleghitekschool 2009-04-01 05:36:47 UTC
Checked and closed by HitekSchool Group 1 as a part of Issue Hunting Party 
regression check.