Issue 82996 - Impossible to open a particular sxw file (loop)
Summary: Impossible to open a particular sxw file (loop)
Status: CLOSED DUPLICATE of issue 81146
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.1.5
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-26 11:05 UTC by jchassler
Modified: 2013-08-07 14:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The sxw document which cannot be open by Writer (25.36 KB, application/vnd.sun.xml.writer)
2007-10-26 11:07 UTC, jchassler
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jchassler 2007-10-26 11:05:31 UTC
This bug also happens in the following versions :
-2.3.0
-1.1.1

Writer cannot manage to open a particular file (see attachment).
Writer show a grey page and seems to be lost in a infinite loop or something 
like that.

We try to investigate what could cause the trouble in the content.xml and 
styles.xml
First fact :
Inside the content.xml file, we saw that there is a text:section that includes 
a text:section-source inside a table:table ; if we move the text:section 
outside the table:table, openoffice can open the file without any problem.
Second fact :
Inside the styles.xml file, if we set the fo:keep-with-next propertie of 
the "HLX antériorité" style to "false", the document can also be opened 
without any problem independantly of the position of the text:section in the 
content.xml.
Comment 1 jchassler 2007-10-26 11:07:43 UTC
Created attachment 49178 [details]
The sxw document which cannot be open by Writer
Comment 2 michael.ruess 2007-10-26 11:52:15 UTC
This has been fixed by issue 81146 for OO 2.4 release.
Try out with dev build 680m230 or newer.

*** This issue has been marked as a duplicate of 81146 ***
Comment 3 michael.ruess 2007-10-26 11:53:02 UTC
Closing duplicate.