Issue 83001 - Open/Save Word 2007 Docx documents
Summary: Open/Save Word 2007 Docx documents
Status: CLOSED DUPLICATE of issue 60586
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-10-26 13:42 UTC by medentmatt
Modified: 2008-10-16 11:31 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description medentmatt 2007-10-26 13:42:14 UTC
I searched for this request but could not find it which surprised me so if this 
case exists, please link it in.

This request is to have the ability to open and save documents to the Word 2007 
docx format.
Comment 1 crxssi 2007-10-26 20:09:24 UTC
I also searched and could not find an issue about docx, other than yours.  This
surprises me, too.  The docx file format is still rather new, but it has been
out for several months and my users are already starting to get them every now
and then.

In the coming months/years, it will be critical to have the ability to not only
open but also save OO files in .docx format (unfortunately).

There is a method for converting them on the command line using a utility from
Novel called "OdfConverter"- but it is released as a Linux binary-only. Some
info here: 
http://geekhacks.blogspot.com/2007/05/working-with-word-2007-documentsdocx-in.html
Comment 2 aziem 2007-10-27 16:37:58 UTC
Duplicate to issue 60586

*** This issue has been marked as a duplicate of 60586 ***
Comment 3 aziem 2007-10-27 16:39:13 UTC
close duplicate
Comment 4 dj_dick 2008-10-16 09:10:24 UTC
Excuse me but although issue 60586 is marked as fixed, OpenOffice 3.0 is able to
open (import) DOCX documents, not to save them!

Is the saving/export of Office Open XML planned? 
Comment 5 michael.ruess 2008-10-16 11:31:32 UTC
Yes, the export is planned but we cannot give an exact schedule for this. Sorry.