Issue 83023 - DateTime fields lose date information when imported from MS-XML via XSLT
Summary: DateTime fields lose date information when imported from MS-XML via XSLT
Status: CLOSED DUPLICATE of issue 82849
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.3
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-26 20:10 UTC by slowfox71
Modified: 2007-10-29 13:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description slowfox71 2007-10-26 20:10:31 UTC
When importing a MS-XML spreadsheet containing DateTime fields, only the time
portion is imported, date information is lost irrecoverably. A small sample file is:

------------------------------------------------------------------
<?xml version="1.0"?>
<?mso-application progid="Excel.Sheet"?>
<Workbook xmlns="urn:schemas-microsoft-com:office:spreadsheet"
   xmlns:x="urn:schemas-microsoft-com:office:excel"
      xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet"
         xmlns:html="http://www.w3.org/TR/REC-html40">

<ss:Styles>
        <ss:Style ss:ID="prefaceDate">
                <ss:NumberFormat ss:Format="DD.MM.YYYY, hh:mm" />
        </ss:Style>
</ss:Styles>
<Worksheet>
<ss:Table>
<ss:Row>
        <ss:Cell ss:StyleID="prefaceDate">
                <ss:Data ss:Type="DateTime">2007-10-26T15:42:42</ss:Data>
        </ss:Cell>
</ss:Row>
</ss:Table>
</Worksheet>
</Workbook>
---------------------------------------------------------------------

The problem seems to be located in
share/xslt/import/spreadsheet/spreadsheetml2000.xsl around line 6665,
where either the date or the time from the original file is used, but
not both parts.
Comment 1 frank 2007-10-29 13:26:48 UTC
double to Issue 82849

*** This issue has been marked as a duplicate of 82849 ***
Comment 2 frank 2007-10-29 13:27:10 UTC
closed double