Issue 8304 - Install GPL wordlist from the installation program
Summary: Install GPL wordlist from the installation program
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P4 Trivial with 10 votes (vote)
Target Milestone: OOo 2.0
Assignee: Martin Hollmichel
QA Contact: issues@installation
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-10-13 22:32 UTC by ooo
Modified: 2006-04-04 07:47 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ooo 2002-10-13 22:32:55 UTC
A lot of wordlist is licensed under GPL so they can't be integrated in 
OpenOffice.org and distributed. 
 
But there is no problem in distributing OpenOffice.org and the GPL wordlists 
together. 
 
There is also no problem in installing the GPL wordlist from the 
OpenOffice.org installer. 
 
So I have a double suggestion: 
 
Make it possible to install a GPL wordlist from within the OpenOffice.org 
installer (where the user can search his drives for the correct wordlist 
files). 
 
Distribute OpenOffice.org with the GPL wordlists and let the installer handle 
them automatically.
Comment 1 Olaf Felka 2002-10-14 15:07:27 UTC
Falko,
Please have a look.
Comment 2 simonbr 2002-10-14 17:53:05 UTC
Maybe a more generic solution: to provide the installation script 
with an interface for a plugin, i.e. an external program which is 
called by the installation script to install additional stuff. There 
should be a mechanism to pass it some information such as install 
directories, etc. 
Comment 3 Unknown 2002-10-17 12:20:04 UTC
*** This issue has been confirmed by popular vote. ***
Comment 4 moy 2003-02-07 15:22:51 UTC
I have one more question:

The software dictinstall (http://www.ooodocs.org/dictinstall/) does
exactly that job, and is licenced under the LGPL.

Why can't it be included in the installer of OOo ? (Maybe because it's
not multiplatform ?)
Comment 5 khendricks 2003-02-18 13:16:43 UTC
Hi, 
 
Adding myself to CC on this one. 
 
Kevin 
  
Comment 6 khendricks 2003-03-24 18:45:35 UTC
Hi, 
 
Any further info or comments on this one? 
 
Thanks, 
 
Kevin 
 
Comment 7 falko.tesch 2003-09-10 14:26:34 UTC
Sorry, but GPL wordlists are more or less an exclusive appearance
unter *nix. At least I don't know nothing about these list under
Windows systems.
Furthermore there are already effort underway to bring alternative
spell-checker et al into OO.o.
Comment 8 khendricks 2003-09-10 16:22:25 UTC
KH -> FT,

Based on your response I don't think you really understand the issue at all.

There are numerous spellcheck dictionaries available from http://
lingucomponent.openoffice.org/download_dictionary.html

These dictionaries will and do  work with the OOo spellchecker under ALL platforms 
(not just *nix).

Many of these dictionaries are covered under the GPL license which precludes them 
from being integrated into the main CVS tree.

If there was some sort of "hook" that could be added to the installation program so 
that a script or another program could be automatcially run right before installation 
completes, then volunteers could write the code to automatically insall the GPL 
dictionaries for users (on any platform ... windows included!).

So what this issue was about was to add some sort of hook or technique or code to 
the current installation program that would also install dictionaries (GPL or not) if 
present in the main installation location, or at least fork and execute an external 
script so that some other program can handle that.

So whatever solution is done for the new installer should include a hook to add in 
other packages (via script or program or whatever) for ALL platforms, not just *nix.

Kevin


Many of these 
Comment 9 Martin Hollmichel 2003-09-10 16:46:44 UTC
I will have a second look on this.
Comment 10 Martin Hollmichel 2003-09-10 16:48:10 UTC
reassigned to myself.
Comment 11 pavel 2005-02-12 00:18:52 UTC
mh: looks like we now have OOoDic -> I'd suggest to close this as WORKSFORME.
Comment 12 Martin Hollmichel 2005-06-17 16:40:17 UTC
treat issue as suggested.
Comment 13 Martin Hollmichel 2006-04-04 07:47:55 UTC
close issue.