Issue 83060 - After upgrade from 2.2 to 2.3.0 cannot open file from former release
Summary: After upgrade from 2.2 to 2.3.0 cannot open file from former release
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.3
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: frank
QA Contact: issues@sc
URL:
Keywords: oooqa, regression
Depends on:
Blocks:
 
Reported: 2007-10-28 16:30 UTC by kalaphew
Modified: 2013-08-07 15:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
the file I cannot open with 2.3.0 but that I could open with 2.2 before upgrading (92.89 KB, text/plain)
2007-10-28 16:33 UTC, kalaphew
no flags Details
faulty notes removed (96.47 KB, application/vnd.oasis.opendocument.spreadsheet)
2007-10-28 22:27 UTC, Regina Henschel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kalaphew 2007-10-28 16:30:55 UTC
After upgrade from 2.2 to 2.3.0, I cannot open anymore one spreadsheet created 
with 2.2. Others can be opened, I would like to send you the file, but I do not 
see anyway to attach a file to this document.
Comment 1 kalaphew 2007-10-28 16:33:27 UTC
Created attachment 49205 [details]
the file I cannot open with 2.3.0 but that I could open with 2.2 before upgrading
Comment 2 Regina Henschel 2007-10-28 20:17:49 UTC
I can confirm the issue with SRC680m233 on WinXP. OOo hangs while loading. The
problem is connected with the table "Common box". If you delete this table, the
file opens normal.
Comment 3 kalaphew 2007-10-28 21:25:05 UTC
Hi,

First all, I do really appreciate how quick I have got a first answer.

You wrote : "OOo hangs while loading. The problem is connected with the 
table "Common box". If you delete this table, the file opens normal."

Some comments / questions:

- How can I delete the table commom box; I can not edit the file in 2.3
- This table contains data and I would like to keep this data. So, is there a 
correction allowing that 2.3 supports files created in 2.2?

PS: I removed release 2.3 and re-installed version 2.2 ... in 2.2 I do not face 
this problem.

Comment 4 Regina Henschel 2007-10-28 22:26:06 UTC
I think, I find, what is wrong with that table.
Open the file in OOo2.2.
Open the Navigator and therein the part 'Notes'. You will see some notes with
text in non latin font.
Delete all this notes. (If you doubleclick the note in the Navigator the
corresponding cell is active and you can delete the note out of the context menu.)
Save the document with a new name.
The repaired file should open fine in OOo2.3

I'll attach the file with removed notes.

Can you tell us something about this notes?
Comment 5 Regina Henschel 2007-10-28 22:27:27 UTC
Created attachment 49213 [details]
faulty notes removed
Comment 6 frank 2007-10-29 10:30:22 UTC
Hi Daniel,

Notes are your construction site as far as I know. The Notes seems to be with
Thai Characters.

Frank
Comment 7 kalaphew 2007-10-29 19:56:14 UTC
Thanks to all. Right, it is Thai characters. 
Is it planned to get a patch to correct it in 2.3 or should we wait till the 
2.4 version? 
Comment 8 daniel.rentz 2007-12-13 09:08:18 UTC
cannot reproduce in OOo 2.3.1
Comment 9 daniel.rentz 2007-12-13 09:09:45 UTC
back to QA
Comment 10 frank 2007-12-13 09:29:44 UTC
Yeeep, 2.3.1 does not show the described behaviour, therefore closed.

Frank