Issue 83082 - RPT: In grouping dialog the delete is not ease to find
RPT: In grouping dialog the delete is not ease to find
Status: CLOSED FIXED
Product: Base
Classification: Application
Component: code
680m234
All All
: P3 trivial (vote)
: OOo 3.2
Assigned To: marc.neumann
issues@dba
:
: 83895 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 14:03 UTC by lars.langhans
Modified: 2009-06-01 04:07 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Sorting and Grouping with delete column (27.85 KB, image/png)
2007-10-29 14:05 UTC, lars.langhans
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lars.langhans 2007-10-29 14:03:21 UTC
We should offer a extra colum with a small 'X' to delete existing grouping, if
there exist a group,
because it took too long to realise that the right mouse button has a 'delete
entry'.

Sample, take a look in the nice attachment.
Comment 1 lars.langhans 2007-10-29 14:05:01 UTC
Created attachment 49235 [details]
Sorting and Grouping with delete column
Comment 2 Frank Schönheit 2007-10-29 14:07:30 UTC
Nice. Do it :)
Comment 3 lars.langhans 2008-05-29 08:46:26 UTC
target change
Comment 4 lars.langhans 2008-11-24 07:26:38 UTC
*** Issue 83895 has been marked as a duplicate of this issue. ***
Comment 5 bettina.haberer 2008-11-24 14:31:06 UTC
@lla: Please take over the attachment from 83895 into this issue. 
Comment 6 Frank Schönheit 2008-11-24 14:53:19 UTC
fs->bh: I disagree with your idea of making the arrow black instead of green,
for the following reasons:
- it's inconsistent: I do not know any other place which uses a black arrow
  for this purpose, but there are places which use *exactly* the same green
  arrow:
  - the table designer
  - the table data view
  - table controls in forms
- it's ugly.
  Admittedly, this is a matter of taste :)
- Changing this requires a lot of implementation effort, since (see above)
  the respective control is used in multiple different places, and *always*
  uses a green arrow - changing this to black for only one use case requires
  disproportional effort, IMO.
Comment 7 Frank Schönheit 2008-11-24 14:54:43 UTC
fs->lla: Before actually doing the change requested in issue 83895, please wait
for Bettina's feedback regarding the points I made above. I am really reluctant
about you implementing this without convincing arguments.
Comment 8 lars.langhans 2008-11-28 08:34:11 UTC
fixed.
Comment 9 Frank Schönheit 2009-02-26 12:36:46 UTC
targeting to 3.2, since the fix is part of a CWS aiming for this release
Comment 10 lars.langhans 2009-02-27 09:30:24 UTC
please verify
Comment 11 marc.neumann 2009-04-02 09:12:07 UTC
reopen because there i no delete column as described in this issue
Comment 12 marc.neumann 2009-04-02 09:15:47 UTC
reassign back to lla
Comment 13 ocke.janssen 2009-04-06 07:07:48 UTC
The sorting and Grouping dialog now offers a toolbar below the groups box. There
you can change the order of the groups and you can delete one group with the red
cross.
Comment 14 ocke.janssen 2009-04-06 07:09:14 UTC
Please verify. Thanks.
Comment 15 marc.neumann 2009-04-14 13:09:07 UTC
verified in CWS dba32a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32a
Comment 16 drewjensen.inbox 2009-06-01 04:07:17 UTC
Checked w/ DEV300_m49, SRB 1.1.0

Closing