Issue 83216 - Break file link to JPG in simpress causes file to be huge and unmanagable
Summary: Break file link to JPG in simpress causes file to be huge and unmanagable
Status: CLOSED DUPLICATE of issue 15508
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: OOo 2.3
Hardware: All Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: christian.guenther
QA Contact: issues@graphics
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-11-01 19:46 UTC by swingkyd
Modified: 2007-11-02 10:22 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description swingkyd 2007-11-01 19:46:08 UTC
Description:
I have a presentation with 30 slides. Presentation created with each slide
containing a link to an ~1MB jpg image. The purpose is to keep the resolution
high for press purposes. Anyway, while the linked spreadsheet is slow, the size
is only 113kB... expected result of course. But, now when I go "Edit->Links" and
break all of them, then save, the file takes 5 minutes to save. A closer
inspection of the now 260MB file after unzipping it shows all the JPG images are
exported to 10MB png files. So, my original files which were about 35MB changed
to 260MB and it becomes completely unbearable to work with. 
Competitor product after exporting linked file to PPT becomes about 37MB and is
easily manipulated and worked on.
So is this a bug? Well, maybe it's an enhancement which is a high priority. Not
only is this an issue with this program but it also affects Draw. 

It seems crazy that 30MB of images changes to 260MB. the best png compression I
could get on a sample file is converting from 1,126kB JPG to 8,525kB PNG using
GIMP. So that is why they get big...
There just has to be a better way. What about natively keeping the JPG format
instead of using PNG? would that speed things up? It would certainly keep things
smaller.

Steps to reproduce:
1) Create a presentation
2) link a sample image using "Insert->Picture->From File" fine a 1MB JPG and
link to it (check box "Link")
3) Duplicate this slide to about 30 (you don't need to use 30 separate files
like in mine)
4) Save the file
5) Save a copy of the file
6) Open one of them, go : "Edit->Links" in "normal" view and break all the links.
7) Save (go for coffee, have a break, run a mile and come back)
8) look at file size. Examine "Pictures" subdirectory in xml file. Should be
full of 10MB files. Try to do anything in the file... should be slooow.
9) Save again... (go for coffee...etc)
Comment 1 swingkyd 2007-11-01 19:53:33 UTC
Re-named title slightly
Comment 2 ace_dent 2007-11-02 10:22:00 UTC
This is a known defect. See Issue 15508 and feel free to add your comments and vote.
Cheers.

*** This issue has been marked as a duplicate of 15508 ***
Comment 3 ace_dent 2007-11-02 10:22:31 UTC
Closed duplicate.